Topic | Android BLE Connection Problems

Home Forums Mooshimeter Support Android BLE Connection Problems

Viewing 11 reply threads
  • Author
    • #15232 Reply

      So I wanted to Log some measurements today and had some funny connection issues, was finally able to connect and I think make a few Logs.

      Then I shut off Logging, and wanted to reconnect and download the Log files as they were small.

      Then the problems started, I cannot reliably reconnect on my Android which has been working to date the few times I have used the meter.

      So the scan shows the meter, but I cannot connect.

      I can see the meter, RSSI is -53 dBm but I keep getting Initialization failed. Status: -1.

      Went and grabbed the iPad, it connects no problem. Shut off BT on the iPad. Restated the Android a number of times, power the BT Off an On, removed batteries from the meter, pressed and help the reset on the meter, finally used the iPad to put the meter in shipping mode, then shut the BT off on the iPad. Then woke the meter up and was able to connect, but then I disconnected and it the Android would not reconnect again.

      Seems that when I search on my Android with the BT, it wants to pair with a code, 0000 and 1234 do nothing.

      I am not sure what the heck has happened and what is going on.

      Is there a way to debug what is going on??

      Seems that Android is just not reliable regarding connecting to the meter.


    • #15238 Reply

      So to update what I have been able to find out so far.

      Still had problems connecting with my Android so I turned on the BT on the iPad, was able to find and connect to the meter without problems from the other room in the house.

      Put the meter in shipping mode.

      Woke the meter up, tried to connect, no luck.

      Uninstalled the App from my Android, power cycled the Android, reinstalled the App, no luck.

      Checked for updates and when updates were installed on my Android and nothing appears to be newer than when I received the meter.

      Something strange is going on as I was able to “reasonably” connect with this Android previously.

    • #15244 Reply

      Hi jfoj,

      I am sad to say that you’ve tried everything I would recommend trying. “Status -1” is a timeout, which can happen to any of the Android BLE related functions, so unfortunately that doesn’t narrow down the problem-hunting much.

      Android BLE has been problematic since the beginning. If you’re using Android 4.3 or 4.4, I would look at upgrading, as later releases can be more stable. This varies by manufacturer though… the Android landscape is far less consistent than Apple.

      One other thing that could help – on some Android phones the wifi and BLE do not co-exist nicely. Can you try again after turning off the wifi connection?

      I’m sorry I don’t have any surefire answers on this issue, hope this helps

    • #15247 Reply

      So here is the weird/interesting part of all of this.

      I have another Android tablet that I downloaded install the App on and I was able to connect up without a problem.

      So it appears to be a problem with the one specific Android tablet, BUT, up until recently I had not had a problem with this specific tablet.

      So the problem tablet is a Samsung Galaxy Tab A Model number SMT350 with Android Version 6.0.1 installed. I do not believe there have been any updates SINCE I purchased the Mooshimeter, but it may be possible. Looking over the About Device the most recent updates appeared to be Nov 16, 2016. I did not order the meter until Nov 18, 2016.

      The older Android tablet that seems to play nice is a LG V400 with Android version 5.0.2.

      The only thing that I can see that is different is the Samsung (problem tablet) has the BT connection show up and seems to want to Pair, the LG tablet does not appear to require/attempt to pair. Maybe there is a newer “security” feature that was added/updated for the Bluetooth connection??

      Anyone else have ideas/thoughts??

      Maybe there is some hook needed in the App to have the newer Android OS ignore attempts to pair the Bluetooth for the meter??


    • #15249 Reply

      I noticed similar differences between the following two devices:

      • Wiko JERRY smartphone (Android 6.0.?) seemed to need pairing, it accepted the PIN “00000000”, but even then it didn’t connect properly in abt. 49 of 50 cases or so. In other words: it worked almost never.
      • NEXUS 7 (2013) tablet (Android 6.0.x) is always connecting reliably and flawlessly – without explicit pairing.

      (As I could always switch to the tablet, the not-working phone wasn’t a big problem for me, so I didn’t mention it here until now. But the problem existed from the beginning, that is, since october when I got my mooshimeter.)

      Some weird details with the problematic JERRY phone (and possibly other devices with similar behavior) may be of interest for you, @James:

      I discovered a different behavior after the recent app update to version 1.0.34 (2115). At my very first attempt with the updated app, it surprisingly connected without problems, but I was “forced” to do a firmware update, although it reported the same version numbers (1477971088) for both the currently installed and the offered “new” firmware. Somewhat perplexed, I agreed to make the “update” – and wasn’t bothered again afterwards. Since then, the BLE connection appeared to be very robust – it connected always without problems and sometimes even without pairing.

      But the joy didn’t last long – after the next reboot of the phone all the old connection problems were back. :-(

      After this disappointment, I tend to assume that spurious effects – and not the app update itself – caused the connection to work temporarily. At least, it’s now proven that it CAN work reliably, but seems that this is depending on some kind of unknown “statefulness”. Seems almost impossible to find the concrete flaw…

    • #15273 Reply

      To update, I was able to get my Android that was running 6.0.1 to reconnect to the Mooshimeter which worked before then started to have problems and would no longer connect properly, I cleared the Cache on the Network Settings and so far this is helped resolve the issue.

      Go to Settings > Backup and reset > Network settings reset to clear all your connection data. This includes Bluetooth and cellular data, so you’ll need to reconfigure everything afterwards.

      But after doing this, the App connected to the meter flawlessly.

      One thing that still happens is if you search for BT connections, the BLE Meter will show up, BUT DO NOT ATTEMPT TO PAIR YOUR ANDROID WITH THE METER. Just close the BT control screen and if you attempt to Pair the meter with the device, you will probably need to go back and clear the Network Setting Cache again.

    • #15274 Reply

      There seems to be some issues/changes starting with the Android Marshmallow 6.0.0/6.0.1 OS. 6.0.1 may have solved the problem on some Android models, however, there seems to be Bluetooth problems with Marshmallow 6.0.x.

      As I mentioned, DO NOT attempt to Pair the meter with the Android device, I think if you attempt to Pair the meter this is when Bluetooth problems come up.

    • #15294 Reply

      Hi jfoj and Manfred,

      jfoj –
      Thanks for the details, especially regarding early Android Marshmallow releases.

      Regarding the question: “Maybe there is some hook needed in the App to have the newer Android OS ignore attempts to pair the Bluetooth for the meter?” – I haven’t found one unfortunately. The app does not have much control over how Android decides to discover and cache bluetooth devices and all the manufacturers do it a little differently.

      You should never need to pair your phone with the Mooshimeter, regardless of Android version. It still mystifies me why some Android phones continue to prompt the user for this.

      Very interesting that you saw a change in connection behavior after an app update. I think, like many things about Android BLE, it is a matter of certain cached values in the OS being cleared upon re-installation of the app. Other customers have seen a change in behavior upon deleting and re-installing the app, and in the most recent app update the changes were all in processing and new features, not in the core connection logic.

      Sorry to give a bunch of non-answers, but I think both of you have found the edge of my knowledge regarding Android BLE. I can say that it’s gotten better since I first released the Mooshimeter (Android 4.4 was a special kind of nightmare), so the direction is good even if the speed is lacking.


    • #15295 Reply


      Just trying to get as much useful info out here for users and yourself when people run into problems. Hopefully this will cut down on possible returns and allow people to work around any specific communication problem.

      I think something happened with the Marshmallow Android release as my other Android is a pre-Marshmallow OS.

      Will update if I find anything further info.

    • #19663 Reply

      Just a pleasant update to my more-than-one-year-old previous posting in this thread. (2nd try, after my first some days ago went to nirvana.)

      As told, BLE connection with my WIKO JERRY smartphone was working almost never, but still often enough to demonstrate that in principle the hardware is able to do it. But in abt. 49 of 50 cases, it didn’t for unknown reasons.

      Many other devices seemed to have similar problems.

      In the meantime, some update (OS? Some app? No clue) must have changed the behavior. After confirming the mooshimeter app’s request to enable BT, I got the following “new” message (which I can’t remember to have seen before):

      Android Marshmallow (6.0+) requires Location Services for improved Bluetooth device scanning. While it is not required, it is recommended that Location Services are turned on to improve device discovery.

      Heureka! If I accept, the connection works always reliably!

      (Normally, I have Location turned off to save energy, and without this hint, I would never have had the idea to turn it on for BT use…)

      It seems somewhat strange: why should local BT device discovery depend on “global” location information? What have these two very different things to do with each other? It has been reported to google as a bug, but they stated that it won’t be fixed as it is intended.

      See for more details.

    • #19834 Reply

      I am also having connection problems using my LG G4. It requires a PIN. Makes no difference if I try from in the system BT screen or the Mooshi screen. Occasionally I do succede in connecting (I have not worked out why) but it is so rare that I basically dont bother. Network reset seems to have no effect.

      A Nexus 7 is a bit (BT) clunky but is useable.

      I wonder if Mooshi is doing any work to resolve this issue as it seems to be quite common. Is Mooshi releasing test versions to users to try and find a solution. For example, how about a version that explicitely requires a pairing PIN eg 0000 . This would not be an inconvenience as it only needs to be done once


    • #19838 Reply

      I am having the same problem with my Xperia Z3 Compact. My phone insists on pairing, but says incorrect pin or passkey, whether I use 0000, 00000000, or 1234. Nothing I have tried has worked.

Viewing 11 reply threads
Reply To: Android BLE Connection Problems
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.