Topic | Android phone doesn\\\'t connect to mooshimeter

Home Forums Mooshimeter Support Android phone doesn\\\'t connect to mooshimeter

Viewing 11 reply threads
  • Author
    Posts
    • #9172 Reply
      Anonymous
      Guest

      I’m using a Motorola moto g running Android 6.0 that previously connected to my mooshimeter. I didn’t use it for a few weeks and tried to connect yesterday after several attempts, it asked for a pairing code. I gave it the 0000 and it said it was incorrect. I tried to scan for the mooshimeter ever since and my phone just will not find it. The unit blinks every two seconds. Where do I go from here?

    • #9199 Reply
      admin
      Keymaster

      Hi Chris,

      That’s very strange, Android should never ask you for a pin code to connect to the Mooshimeter. A few things to try:

      1. Resetting the Mooshimeter (open the case and press the small button on the side under the battery)
      2. Rebooting the phone
      3. Replacing the Mooshimeter batteries

      I haven’t seen anybody else reporting this specific issue, so I’d try those operations first.

      I hope it helps, let me know how it goes. Best
      ~James

    • #9210 Reply
      Anonymous
      Guest

      Got mine yesterday, and it’s exhibiting similar behavior. The phone (Galaxy S4 not rooted) can find and pair with it, but the application will not connect.

      It previously worked until I decided to put it to sleep, since coming out of hibernation…the behavior above.

      I also get the password request whenever I unpair and re-pair. In my case, the password turned out to eight zeros (00000000). I tried four (0000) and it didn’t work.

    • #9211 Reply
      Anonymous
      Guest

      UPDATE: Rebooting my phone fixed everything.

    • #10523 Reply
      Anonymous
      Guest

      Same issues as above:

      Moto G, Marshmellow-Download app. gives 2 icons: “data logger” and “Mooshi”. Does not connect bluetooth to Mooshi under Android settings (usually does not see the hardware, even when shown, will not pair).

      It does connect using Mooshi icon/app. updates screen, shows graph on horizontal etc. Also. will log onto SD card. It seems to accept different sample rates, but it actually does not change the sample rate of 3-4 sample/second.

      Even though Mooshi app. connects, “Data logger” can’t find it “device not found”. Also, even when Mooshi connects, it does not show as paired under Android settings.

      Changed batteries, many reboots of phone and Mooshimeter, reloaded app, tried many different sequences in different orders etc. Occationally, (fresh reboot on both Mooshimeter and phone), Android settings bluetooth will show Mooshi and asks for code. However, it has never actually paired. “Data Logger” also sometimes shows the Mooshi, but does not connect.

      Also tried with Moto G, with Lollipop. App. only shows 1 icon (no Data Logger icon, just Mooshi). Similar behavior as above.

      Also tried Ipad Air (should have BLE, latest IOS). App. only shows 1 icon (Mooshi). Does not show hardware in IOS settings, will not connect.

      Is there a basic writeup on how the software is supposed to work?

      Help! Can’t live with 3 samples/sec.

      Tad

    • #10525 Reply
      admin
      Keymaster

      Hi Jakdedert,

      Thanks for recording what you saw even though you found a fix for it all. It’s helpful to know what’s going on, and reassures me that when I recommend a phone reboot as a first step, it’s valid.

      Hi Tad,

      The simplest way to raise the sample rate you’re seeing on the SD card would be to make sure the logging is set to “MAX” or “No delay” and raising the sample rate in the metering screen. When measuring with default settings, you’ll see 125Hz/32smpl on the metering screen. Tapping the sample rate will let you change it and raise the rate.

      Hope this helps
      ~James

    • #10526 Reply
      Anonymous
      Guest

      Just to update:installed firmware v 1447458797. Still have the same problems. Rebooted both mooshimeter and phone. Uninstalled and reinstalled Android app. Only have 1 icon now, but still logs at approx. every 0.31 secs, no matter what interval is chosen

    • #10529 Reply
      Anonymous
      Guest

      Hi James,

      I do not want to raise the sampling rate, I want to lower it to a sample rate of 1 sample every 10 seconds or 1 every minute. Selecting these options does not change the sample rate. When I return to the main screen, it says “accepting preferences” (or something similar), but the sample rate stays at about 3 samples/second using 32 samples, 125 hz.

      Using 256 averages slows it down to a sample every couple of seconds, but I don’t want that much smoothing.

      I need to take weeks of data. At 3samples/sec., the amount of data will not be managable.

    • #10536 Reply
      Anonymous
      Guest

      Hi Tad,
      I am a user just like you. Maybe you want to change the “Logging Interval” not the sampling rate. On the screen where the measured values are displayed, pressing settings in upper right corner, then Logging Interval, then select 1min or whatever you want, then press upper left arrow to go back to main display. The logging interval of 1min will write one timestamp, chan1 value, chan2 value to the SD card every one min. If the app display is not active while logging, the meter will sleep more to extend battery life.
      — Duane

    • #10539 Reply
      Anonymous
      Guest

      Sorry, I thought I was clear. Perhaps it is the nomenclature.

      I am trying to set the logging interval. I go to the upper right of the main screen to select preferences. I come to the screen that allows you to set logging interval: max, 1 sec, 10 seconds, 1 minute.

      I select (for example) 1 minute. The 1 minute button turns gree. I return to the main screen. It says “applying preferences”. I press “logging on”. the button turns green.

      When I read the data from the SD card, I get a data point every 0.301 seconds, so the logging rate is about 3 samples/second. It does not matter if I select 1 sec, 10 sec or 1 minute, the logging rate does not change. It is always approx. 3 samples/second.

      I have rebooted phone and Mooshimeter many times, tried various order of sequences. I have upgraded firmware, reinstalled the app. The set logging rate does not work at all.

      I have tried 5 different devices, different phones, different Android versions (v 6, V5) as well as IOS. The behavior is the same. There is no way to change the logging rate with any device.

      I really like the Moshimeter idea, but this unit is not performing properly.

      If no one can assist in troubleshooting, I will have to return it.

    • #10542 Reply
      Anonymous
      Guest

      @Tad. This might be stupid question, but do you have your phone always connected to you mooshimeter while logging?

      At some point, it was (or still is) default behaviour to log as much as possible while connected and slow down to desired logging rate after phone is disconnected from mooshi.. I’m pretty sure there was discussion of that behaviour some time ago and how confusing that is and it might have been fixed. Or not.. Have to come up with something real to log myself.. Hmm.. Heatpump might give something interesting to see.

    • #10546 Reply
      Anonymous
      Guest

      Thanks Ville.

      Success! I thought I had tried every permutation, but I had not tried completely closing the app. I have navigated out of the app. I have lost connection. But I never completely closed the app., and this did the trick!

      James-Adding these few steps somewhere in the docs. may save someone else from 3 days of frustration. I know that development is really tough, but if people can’t get it to work…

      My procedure:

      Completely close app. by swiping.
      Insert card
      Reboot Mooshimeter hardware
      open app and connect
      From main screen, press upper right corner (looks like settings)
      new page shows logging intervals
      select desired interval, slight delay, selection turns green
      go back to main screen (press android “go back”) must be done within a few secs.
      Select logging on
      press Android square to bring up open programs, swipe Mooshi app closed
      starts logging at the desired intervals
      led will show flickering every 10 seconds (for 10 sec. interval)

      To stop logging, open app., connect, press logging off
      remove card and read

Viewing 11 reply threads
Reply To: Android phone doesn\\\'t connect to mooshimeter
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.