Topic | Android tried install Build 1426035947

Home Forums Mooshimeter Support Android tried install Build 1426035947

Tagged: 

Viewing 9 reply threads
  • Author
    Posts
    • #10218 Reply
      Anonymous
      Inactive

      My meter has Build 1447470000 , installed by IOS and works perfectly on IPAD.
      When I start the Android-app on my phone I’m asked to install Build 1426035947.
      When I accept I get:
      -Image Loaded
      -Ready to program device!
      -Programming started
      -…
      -Programming cancelled
      -WARNING: NOT ALL BLOCKS CONFIRMED

      Android App installed is the app.apk (2016-04-12 19:14) from moosh.im/s

    • #10221 Reply
      Anonymous
      Guest

      Did you try the “slow” version?

    • #10222 Reply
      Anonymous
      Guest

      Also you could try the Android Beta app – it’ll ask you to install a much newer firmware – but I don’t think you have to for basic functions to work, and I think James is still working out the kings in the beta firmware at the moment. It seems to be much better since yesterdays update for me.

    • #10224 Reply
      admin
      Keymaster

      Thanks Paul – I am actually working on a blog post about the new update so I will ask for comments there.

      Danny – Thank you for bringing this up, I had to restore the whole web server from a backup recently and it looks like some links got screwed up in the system hosting the APKs. Can you download the Mooshimeter app from the google play store? I am going to close the apk folder until I figure out what happened there.

      Thanks
      ~James

    • #10230 Reply
      Anonymous
      Inactive

      Thanks James,
      I can’t download from google play.
      I’ll wait until the system hosting the apk’s is ok.

      Until then I can use the meter with my Ipad.

      Danny

    • #10304 Reply
      admin
      Keymaster

      Hi Danny,

      I updated the folders containing the apk files – you should have access now. Please visit https://moosh.im/s/

      Thanks
      ~James

    • #10313 Reply
      Anonymous
      Inactive

      Thanks James,

      I installed the latest apk.
      At startup the app did an update of the firmware to build: 1466126223. Witch is ok I guess.

      But now the meter got stuck in Bootload-mode.
      I’ve tried a reset, change of batteries, … nothing works. When I start up it gets in bootload.

      The Ipad confirms the build 1466126223 but can’t make a connection with the meter.
      After reset and connect the IOS app reinstalls the build 1447470000. IOS works fine with this (older?) build.

      Any suggestions how I can get things working on the Android phone?

      Danny

    • #10319 Reply
      admin
      Keymaster

      Hi Danny,

      What’s your Android phone and version? Android BLE support is still quite patchy, I’ve learned some of the caveats of the different manufacturers but not all.

      With the Android app – after you successfully uploaded firmware, was the meter blinking on and off slowly and continuously? Or did it give 2 or 3 long slow blinks, then stop, waking up to flash very briefly?

      I’m guessing it’s the latter, and that the issue you’re having on Android sounds like the service discovery bug – Android caches the services offered by the device and sometimes does not clear the cache when reconnecting to the same device. If you want to try to upload beta firmware again, I would try uploading the firmware, then rebooting the Android phone before reconnecting.

      I hope this is helpful, best
      ~James

    • #10325 Reply
      Anonymous
      Inactive

      Hi James,

      After reboot of the phone everything works perfect.
      Thanks for helping me out.

      Cheers!

      Danny

    • #10360 Reply
      admin
      Keymaster

      Very happy to hear, let me know if other troubles arise. Thanks!

Viewing 9 reply threads
Reply To: Android tried install Build 1426035947
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.