Topic | App need firmware update again and again

Home Forums Mooshimeter Support App need firmware update again and again

  • This topic has 0 replies, 2 voices, and was last updated 4 years ago by Anonymous.
Viewing 6 reply threads
  • Author
    Posts
    • #19815 Reply
      Marcin
      Guest

      I have firmware 1477971088. When start app (1.0.38) and connect to meter appear upgrade option (to this same firmware) If I accept, after upgrade sometimes can measure, but mainly again need update. When I reset by getting battery out (reset button never worked for me) sometimes I have initialisation problem, sometimes easy connect and measure. It happen each time I turn on application. And what I observed- consume battery very fast – during 2 months. As an visible change in behaviour – LED blinks for longer time, not short flash as usually. Then I have problem with connecting. In my opinion this problem occurs after last update. please help how to resolve.
      Marcin

    • #19816 Reply
      admin
      Keymaster

      Hi Marcin,

      What kind of phone are you using? Android or iOS? It sounds like it might be Android and that the phone is saving wrong information about the meter, causing connection problems. Can you go to settings->Bluetooth and make sure to delete any pairing information for the meter?

      ~James

    • #19819 Reply
      Anonymous
      Guest

      Hi James
      Yes, I use both Android 6.01 on my phone and 4.42 on tablet.
      Today I connected without a problem (I deleted one Moshimeter pair in bluetooth settings first.) I will observe behaviour by few next days and let you now about my observations.

    • #19886 Reply
      Anonymous
      Guest

      Hi, I have the same problem.

      Running IOS APP 1.12, firmware 1477971088.

      Not always, but very often it asks to upgrade the firmware. Any idea how to fix?

      Thanks
      Andrew

    • #19904 Reply
      Anonymous
      Guest

      Hi, I just bought a meter a week ago from SparkFun since the specs and three leads (current and voltage at the same time) sounded great. I am using Android 9 on Essential Phone PH-1. I have been able to use the meter for about 10 minutes. Now the Android app is stuck in bootloader mode, always wanting to load 1477971088 even though it has that version! It takes over 300 seconds to load and it doesn’t like it if the phone goes to sleep, so I have to disable that… I restarted the phone but now the app says “invalid firmware” and I am loading 1477971088 yet again. But it still insists invalid firmware. If I “continue without updating” at the meter screen, it can’t measure – always “LOADING”. Now after several attempts the batteries are low. I have only gotten about 5 minutes of use out of this brand new meter. How do I return the meter for bootloader repair?

    • #19905 Reply
      Anonymous
      Guest

      Finally, after installing new batteries and removing and reinstalling the Android application I can make measurements. That was almost a 30 minute process. I measured the “dead” AA Duracell MN1500 batteries as 1.35V. The meter was in hibernate mode apart from the first 30 minutes I used it (mostly to download new firmware). How long should the batteries last?

    • #19906 Reply
      Anonymous
      Inactive

      My mooshimeter was in update-loop today. It was working yesterday, but when i tried to use it today, i first realized that led is blinking too often to be on stand by.

      First i tried to reset it, got little further, but it crashed on the main meter screen before i got any results. Then again, update loop. I somehow connected the dots, as i moved the device just when it crashed and then took it fully apart, removed batteries and bend contacts to tighten them. After that, it has worked just fine. It would be nice, if this happens just for bad power connections, as tightening is very easy fix.

      I thought i had heard how that battery indicator works and found this from the admin:
      Regarding battery levels: the indicator in the app is quite rough: 100% means 3.0V or more, 0% means 2.0V or less, and it’s linear in between. The meter shuts off around 2V.

      That was actually part of an answer to my question(s) there:

      Dead batteries just after real logging gig


      Where I got to 1,1 volts per battery.

      Then there is this:

      Short Circuiting Battery Problem

      It should not be a huge problem with newer devices, but it is still possible to cut through battery insulation and short circuit those. I have added kapton-tape over my battery holders, just to be sure.

Viewing 6 reply threads
Reply To: App need firmware update again and again
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.