Topic | Auxiliary Voltage DC value creeping toward negative 1.2V

Home Forums Mooshimeter Support Auxiliary Voltage DC value creeping toward negative 1.2V

Viewing 6 reply threads
  • Author
    Posts
    • #15206 Reply
      Anonymous
      Inactive

      I just got my Mooshimeter and paired with Fairphone 2 using Android 5.1 and also updated the firmware to 1477971088

      When using the Auxiliary voltage DC channel the reading gradually creeps toward the negative range of the channel -1.2V. This can be observed in both cases with leads connected or not. If I shorten the probes the reading goes back to near 0 but as soon as they are disconnected the voltage starts changing toward negative 1.2V

      Also when I tried to measure a rechargeable battery the measurement was pretty close to the one measured on the DC voltage channel. However the two measurements behaved quite differently once I disconnect the probes. The value of the auxiliary channel starts dropping very slowly toward 0 ans remains equal to the initial measurement for a very long time compared to the main voltage channel which goes quickly back to noise level.

      Is this behavior normal and should I trust the measured value ?
      Is it still going to be possible to measure micro Volts with this constant drift ?

      Thank you,
      Hristo

    • #15207 Reply
      Anonymous
      Inactive

      This is a screen capture of the Auxiliary Voltage DC channel creeping

    • #15209 Reply
      Anonymous
      Inactive

      Seems to be the normal behavior of a “floating” high-impedance input, I guess. It accumulates some charge from surrounding electric fields. In my opinion, it’s completely normal and no reason to worry.

    • #15212 Reply
      admin
      Keymaster

      Hi Aladjov,

      Manfred is correct. The high voltage input has a voltage divider at its input, scaling the high voltage down to a voltage appropriate for the ADC. A side effect of this is that when nothing is connected at the input, the ADC input is clamped to zero.

      On the auxiliary input, there is no input voltage divider, the path from the terminal to the ADC has only a few protection components attached. Part of the protection is a set of diodes connected to the power rails, which will leak very small amounts of charge. I believe it’s this leakage that’s causing the drift you are seeing.

      Anyway, long story short, it’s normal :)

      ~James

    • #15213 Reply
      Anonymous
      Inactive

      Dear Manfred and James,

      Thank you for the prompt and informative answer. I played a bit more and found the meter to be quite responsive, including the auxiliary input, when measuring Peltier and other small sources…

      Thank you
      Hristo

    • #15233 Reply
      Anonymous
      Inactive

      Hi Aladjov,

      did you use 8000Hz sampling rate? If so, reduce to 4000Hz. There is still a bug, which produces strange glitches in any signal you are monitoring, even when you are monitoring the voltage of a battery, which canot change so fast.

      Ulrich

    • #19272 Reply
      Anonymous
      Guest

      I think I ran into this or a similar issue trying to use a type K thermocouple. Graphing internal temp and AUX DC voltage with a K type thermocouple both of them are on a constant slow creep – internal temp on the way down, aux voltage on the way up. When looking at the temp on the main app screen temperature is stable. Is there any way to use graphing with the thermocouple so that it displays the compensated temp rather than the aux DC voltage?

Viewing 6 reply threads
Reply To: Reply #15213 in Auxiliary Voltage DC value creeping toward negative 1.2V
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.
Cancel