Topic | Batteries, take them out…….

Home Forums Mooshimeter Support Batteries, take them out…….

Viewing 2 reply threads
  • Author
    Posts
    • #17795 Reply
      Joe mcpherson
      Guest

      It’s been a few months since I used my meter, grabbed it this morning to take some temp measurements, the inside of the case was white in spots, looked like condensation, wouldn’t turn on.
      The batteries had leaked out, pretty bad, lots of crustyness.

      Like anything, if your not going to use it for awhile, take the batteries out.

    • #17805 Reply
      Anonymous
      Inactive

      I had a similar experience with batteries that were no that old. I wondered even if the standby pulse operation of the meter could actually be causing some of the batteries to fail in a premature way where they could actually leak easier than if the meter was not pulsed.

      See my previous post on this issue here – https://moosh.im/f/topic/issues-and-comments/

    • #18260 Reply
      Anonymous
      Guest

      Me too :( All inside the SD socket :(((

      Mine was an early meter, it might have something to do with the sharp edges on the battery holders shorting the batteries – they were 6 month old Duracells.

      Cleaned up with Vinegar and then lots of rinses, the meter seems to work again, I’ll see about the SD card.

      Moral of the story – take out the batteries like they say you should.

Viewing 2 reply threads
Reply To: Reply #18260 in Batteries, take them out…….
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.
Cancel