Topic | Bug in ohm range

Home Forums Mooshimeter Support Bug in ohm range

Viewing 6 reply threads
  • Author
    Posts
    • #2253 Reply
      Henrik Jensen
      Guest

      I got the meter today, there was no problem activating it or linking it up to the phone.
      As the first test I decided to check it out against me resistor box (7 resistors from 10ohm to 10Mohm 0.01%).
      Autorange did not work, it could not decide what range to use and stepped range up/down continuous for 1k, 10k, 100k and 1M.
      Manual range worked much better, the meter was within 0.2 to 0.3% for most of the resistors, but the 10k range was funny. I connected the meter to 10k and change the range to 10K, readout 9.9916. Disconnected the resistor and reconnected it (Without changing anything), readout 12.6360

      And a wish for the logging: Make it possible to download logging files to the phone, convert to cvs* and send as email, store on dropbox or something similar.
      *Remember that there exist two cvs formats, depending on where you are in the world.

    • #2255 Reply
      Anonymous
      Guest

      A bit more info.
      It stopped stepping up/down in ranges on my resistor box.
      Then I tried with a decade resistor box, changing from 10k to 13k did often trigger the stepping up/down. Going back to 10k stops it.

      The software is Android from today, Mooshimeter is V.1 and I cannot update it.

    • #2258 Reply
      admin
      Keymaster

      This is really helpful Henrik, thank you.

      I think I know what’s happening on your meter, and if it’s happening on yours I suspect it might happen on some others.

      A while ago I found a hardware bug on the meter that I detailed here. The jist of it is that when the current source is operating with very low overhead, it can enter a lockup mode where it reads about 30% higher than it should. I rejiggered the firmware to knock the meter out of lockup in the right conditions, but apparently on some meters the firmware kick is not strong enough to knock the current source out of lockup.

      I think that since your meter seems to have the lockup issue, that’s what’s precipitating the range switching as well. Hooking up a 10k resistor to the 10k range might lock up and read 13k, which causes the range to step up, which changes the current source output from 100uA to 100nA, which alleviates the lockup and causes the meter to read 10k, which causes a range step down, etc.

      Sorry for the run-on sentence. Thinking as I write. I’ll look in to the lockup bug again and see if there’s something I missed in the firmware fix. One idea to try in the meantime is to remove the batteries, clean the circuit board with rubbing alcohol, and try again. You’re international, so a return would take a long time, I think the fastest way to resolve the issue would be to wait for the next firmware version. If that doesn’t work then I’ll happily replace the meter.

      Is it otherwise working for you? Best
      ~James

    • #2260 Reply
      Anonymous
      Guest

      And it returned again.

      I believe that both time it has had the problem was after I had adjusted the sample rate and sample size, one time manually and the other time I selected AC voltage on the other channel.

    • #2266 Reply
      Anonymous
      Guest

      I bought two meters, the other one was a bit harder to get working (It had a dead battery).

      What I really want them for is long time logging (weeks) and hopeful easy transferring of the log files when finished.

      The other meter has exactly the same problem when measuring 13kOhm on auto range. It is trying all the ohm ranges, and does never settle down.

      I did also install the software on a 10″ pad (Android) and had some orientation problems with it. It wanted to show the chart when in portrait orientation (Show in portrait format) and the values when in landscape orientation (But shown in portrait format).

    • #2272 Reply
      admin
      Keymaster

      Thanks Henrik –

      Regarding 10k resistance: If it’s present on both your meters, it’s probably present on more. I can make an adjustment in the app to circumvent that problem for now (a “proper” fix requires a firmware push)

      Regarding orientation: That’s really helpful to know! The app makes its orientation decisions based on the angle of the orientation sensor in the device, but I guess some devices have an orientation sensor that’s 90* offset. That’s frustrating. Added it as an issue on Github.

      Thanks

    • #2281 Reply
      Anonymous
      Guest

      I have noticed the same thing. The auto-ranging function loops with resistors in the 12K to 24.9K range though the 24.9K would occasionaly stablize and read correct. Values outside this range seem to auto range OK. Manual ranging on these values works, but I noticed that if you manualy selected the 1Mohm range with the 12K resistor then switch back to auto ranging, that readings were stable, but touching one resistor lead it would cause it to start looping again.

      Android app v1 on a Droid Maxx

      You have created something unique and usefull.

      Thanks

Viewing 6 reply threads
Reply To: Bug in ohm range
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.