Topic | Can't load firmware

Home Forums Mooshimeter Support Can't load firmware

Viewing 5 reply threads
  • Author
    • #19937 Reply

      I was using the meter, when suddenly the app went into the firmware upload screen, even though the current and new versions of the firmware matched.
      (1522204715). So I let it upload the firmware, but it didn’t quite complete – it got to 326 out of 326 seconds (with the progress bar ALMOST at 100%), but never progressed any further. The LED flashes for about 0.5s, at an interval of about 2s.

      I then dinked around a lot, but I can’t be bothered at the moment describing everything I did. Right now, with fresh batteries (measuring 1.6V each cell), the meter is flashing the aforementioned pattern, with the app frozen as described.

      Samsung Note 5
      Android 7.0

    • #20038 Reply

      I had similar problems both times I upgraded. I tried various things until things worked. These seemed effective for me:
      – hold reset button for 5 seconds
      – uninstall the app and reinstall the app
      – batteries out and back in.

      Also, it seems that whenever you see a upgrade progress appear to complete, and yet the Mooshi still shows the build number on the Scan screen, it does not mean that the upgrade did not work. Because doing one/some of the above steps will cause the Mooshi to then show up with the new build number.

    • #20040 Reply

      Thanks. Mine actually sprung back into life,but I have no idea what I did to make it work again.

      I never got a reply from Mooshim – either here, or via email.

    • #20064 Reply

      Don’t start the firmware upload, it’s not necessary. You need to kill the app via the task manager. If not, the App has still the wrong status and ask again for firmware upload. It’s a common problem, occurs sometimes.

    • #20066 Reply

      I am having the same problem.
      The Mooshimeter worked just fine since I bought it, but it recently wanted to do a firmware update.

      Now it is in an endless loop, it never returns to the operating mode.
      Says Meter disconnected”, then it goes back to page that says “Bootloader Invalid firmware”

      I wish I saw MrPeak’s post a week ago :)
      I guess I’ll need to send Mooshi an e-mail.

    • #20075 Reply

      The firmware update loop is most often caused by low battery voltage, try new batteries, always helps. It’s somewhere in the FAQ also.

Viewing 5 reply threads
Reply To: Can't load firmware
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.