Topic | connection errors

Home Forums Mooshimeter Support connection errors

Viewing 6 reply threads
  • Author
    Posts
    • #13964 Reply
      Anonymous
      Inactive

      When I attempt to connect I get one of two errors, “Initialization failed. Status: -1” or “Connection failed. Status: 133”. The -1 is after attempting to connect, 133 is immediately after hitting the button.

      I’m using a Moto G 3rd gen running Android 6.0. Yesterday I updated the meter to firmware 1470628829. The only anomaly yesterday was that turning on logging would freeze the screen. When I disconnected and reconnected logging was turned off, so I couldn’t log at all. Today I used the meter for 10 minutes and manually disconnected. Now it won’t reconnect. The light on the meter flashes once every 10 seconds, which corresponds to standby mode with no SD card (which is correct, I removed it during troubleshooting yesterday).

      I tried turning off bluetooth. I tried uninstalling and reinstalling the program. I hit the reset button on the meter.

      Thoughts?

    • #13967 Reply
      Anonymous
      Guest

      That firmware is pretty stable. So, I would try
      1. Reboot phone.
      2. Check AA battery voltages.
      3. Try another phone if possible (just to isolate the problem to the meter or the phone).

      Also, I have occasionally got the Initialization Failed and I then try a couple of times to connect to the meter again (not scan again, just connect again).

      Please report back any success or failure for the benefit of others who might run into the same issue.
      – — Duane

    • #13968 Reply
      Anonymous
      Inactive

      Long story short, I reinstalled the same firmware and everything works like before.

      Thanks for the response, Duane. I had tried rebooting the phone. When I was able to connect the app told me the batteries were at 30 something percent. I couldn’t connect normally, but I was still able to update the firmware, so I just updated to the same version again. The connection problem is solved now.
      In standby it blinks twice, SD card mounted. After I connect, it still freezes when I hit the logging button on screen. The last time I hit it the meter went into firmware install mode and wouldn’t connect any other way. That logging button seems to really things up, like it’s logging to the firmware instead of to the memory card. I reinstalled the firmware yet again. Unless you know exactly what the problem is, I’d rather wait for a new forum thread, a new firmware, a later date, and a new memory card to try troubleshooting the logging.

      Thanks!

    • #13970 Reply
      admin
      Keymaster

      Hi Madcow,

      Thanks for the well structured report. I read the description and have a theory:
      – Double blink for status means the SD card is readable and successfully mounted
      – Low battery may be related because…
      – SD card write/erase is the most power hungry activity on the Mooshimeter
      My suspicion is that the reboot in to OAD mode you saw is related to trying to write to SD card. My suspicious are:
      – You have a weak set of batteries and the power spike when writing to SD is causing a reboot
      – The SD card is formatted in some weird way that’s causing the firmware to crash (I’ve seen this happen)
      – The card itself is defective and drawing power above its specification
      Here are the steps I would try:
      – Replace the batteries and format the SD card
      – If the same failure occurs, try a different SD card

      Hope this is helpful, best
      ~James

    • #13994 Reply
      Anonymous
      Inactive

      Thanks, James, replacing the batteries did the trick. I can connect, I can log, everything seems to be working.

    • #14022 Reply
      admin
      Keymaster

      Happy to hear it, thanks for the follow up!

      Also, I found a manufacturing issue that affects batteries and I’m still narrowing down who is affected, please give a quick look to the most recent blog post:

      Short Circuiting Battery Problem

      ~James

    • #17094 Reply
      Anonymous
      Guest

      Hello,

      Yesterday my Mooshimeter was working fine. Today, every time I try to connect, I get Connection failed. Status: 133.

      I changed the batteries in Mooshimeter, cleared app data in phone, and rebooted phone, but nothing helps.

      The is no SD card in Mooshimeter.

      What to do next?

Viewing 6 reply threads
Reply To: connection errors
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.