Topic | Failed to enter OAD mode

Home Forums Mooshimeter Support Failed to enter OAD mode

Viewing 11 reply threads
  • Author
    Posts
    • #10517 Reply
      Peter
      Guest

      I’m trying to update from 1462564395 to 147155160 using Android app 1.0.27 (1974) and consistently get “Failed to enter OAD mode” (see https://goo.gl/photos/sgtkZF92bUZXJwxD9) on my Nexus 6 (running 6.0.1). I’ve tried ticking the “Legacy Mode” button with no change. I’ve also tried pushing the reset button when the app says it’s rebooting the phone and it reports “Initialization failed. Status: -1”.

      Any suggestions on what to try next?

    • #10522 Reply
      Anonymous
      Guest

      Peter,
      Have you tried replacing the batteries in the meter? I’m not sure about OAD specifically, but some folks have had problems with firmware updates if the meter batteries were low.

      Although it sounds like you have tried a few things, here is a list of the easy steps to try based on various posts from James and others in this forum.

      1. In the phone, turn airplane mode off then on. Sometimes that is enough.
      2. Reboot the phone. Sometmes that is enough.
      3. In the phone, go to Settings->Bluetooth->Paired Devices. If the Mooshimeter is listed under paired devices, delete it.
      4. Open the case (2 screws) and press the tiny reset button (near the microSD card slot). This reboots the meter.
      5. Remove the 2 batteries and check their voltage with another meter and replace if low. Some people have had low/dead batteries even if they haven’t used the meter much.
      6. Sometimes the meter thinks it is still in shipping mode, so momentarily short the meter probes between ohm and common.
      7. Uninstall and reinstall the Mooshimeter app.
      8. Try a different phone if possible. Pre-paid phones with android 4.4 or 5 can be obtained on sale for $20 or less (in the USA) and they don’t have to be activated, just use wifi. A dedicated phone for this also frees up your main phone.

      Hope one of these helps your meter.
      — – – – Duane

    • #10533 Reply
      Anonymous
      Guest

      I’d already tried rebooting the meter with the reset button. It’s not in shipping mode because I can connect to it and use it as a meter.

      I’ve tried new batteries, rebooting my phone and using a different phone.

      When I use the released Android app, I can reprogram it back to 1447458797. I’ve installed the beta Android app on another phone with the same results. Based on this, I think the problem is the app not correctly detecting OAD mode following a meter reboot.

    • #10549 Reply
      Anonymous
      Guest

      Peter,
      I am currently using App release 26, FW 1466836533

      I was curious on your problem, so I tried it with the exactly same OAD results as you. So I agree something is wrong with the new firmware updating code. I was able to “continue without updating” and it seems to working with the new App 27 with the older firmware 1466836533.

      Since you say you are on FW 1462564395 now, (that was bundled with App version 22), you are certainly missing a lot of good changes James has made. Unfortunately the Playstore only allows you to install the latest version, so I’m sure James will want to fix this soon. In the meantime, you can always download previous released versions from here https://github.com/mooshim/Mooshimeter-AndroidApp/releases. Release 26 is pretty stable and it has included FW 1466836533. Hopefully you know how to side install apps from unknown sources.
      —- Duane

    • #10560 Reply
      admin
      Keymaster

      Thanks again Duane!

      Peter,

      Sorry for the trouble. In the latest beta Android releases I’m trying to automate the process better but clearly there’s still some more work to do. When you press the reset button does the meter flash slowly and brightly for a few seconds?

      If yes: try to connect to the meter while it’s in that state. You can see an example of me doing this here:

      If the meter never flashes slowly and brightly (one second on, one second off): This would mean your meter is skipping the bootloader mode entirely. I doubt this is the case but please let me know if it is.

      Hope this helps, thank you!
      ~James

    • #10562 Reply
      Anonymous
      Inactive

      I also had the failed to enter OAD mode error when I first tried 1.0.27.

      I followed these steps which seemed to work:

      1. Exit and close the app.
      2. Turn on / off airplane mode.
      3. Fire up app.
      4. Hit reset button on meter.
      5. Wait a second for Bootloader to show up and connect.

      Meter is now successfully running build 1467155160.

    • #10621 Reply
      Anonymous
      Guest

      Thanks to Duane & James for their help.

      I updated my phone to 1.0.28(2031) with 1467155160 firmware and managed to reprogram my meter after a few tries by resetting it and then immediately trying to connect and program it. Unfortunately, it then got stuck in the bootloader and I was forced to reprogram it in Android “slow” mode before it would take (this is with new batteries in the meter and I’ve not needed to use slow mode previously).

      Note that my iPad with release software (1.0.6 from memory) would not connect to the mooshimeter whilst it was in bootloader mode after my first programming attempt.

      I haven’t had a chance to play with the new firmware yet and will provide feedback when I do.

      James: Would you be able to add a description of all the LED flashing modes to the FAQ. ISTR seeing one in a blog entry but that’s less accessible.

    • #10752 Reply
      admin
      Keymaster

      Hi Peter,

      Updating documentation – blink patterns will be here:

      Mooshimeter LED Blink Patterns

      I’m rejiggering the support section of the site, more soon.

      ~James

    • #10758 Reply
      Anonymous
      Guest

      28 –> 29, so fw build is now 1469410939.

      OnePlus Two fails “reset free” update mode, but (for some reason, few failed tries with resetting later) after resetting mooshimeter and connecting while in bootloader mode, update started automatically.. I thought i should cancel it, becouse i had never succesfully updated mooshimeter without lecacy mode, but did not and this time it worked.

      Did i just accidentally press something to start update process or is that some new feature? And what about that reason for lecacy mode stuff.. Is there improvements in recent updates or should i be worried that all my luck went to that one update? :D

    • #13861 Reply
      admin
      Keymaster

      Very late to the thread, but just wanted to say I’m not incredibly surprised that it worked once for you without legacy mode. The Android bug that legacy mode tries to get around is documented here:

      Android Swapping BLE Packet Payloads

      It’s very flaky, which is what makes it hell to debug… it’s inconsistent and timing-based.

      Glad you got the update working.

      ~James

    • #13875 Reply
      Anonymous
      Guest

      Hi James.

      Maybe OnePlus had updated some ble stuff at right about that point, as all fw updates since then (~3 times?) have worked without legacy mode.. And without manually resetting.

    • #13883 Reply
      admin
      Keymaster

      Thanks Ville. I am adding notes on the update process to the wiki here:

      https://moosh.im/wiki/index.php/Upgrading_Firmware

Viewing 11 reply threads
Reply To: Failed to enter OAD mode
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.