Topic | FIrmware 1466039460

Home Forums Mooshimeter Support FIrmware 1466039460

Viewing 10 reply threads
  • Author
    Posts
    • #10203 Reply
      Paul
      Guest

      I’ve updated (tried several times to flash – “invalid firmware” a few times, the slow method worked eventually).

      The new graph shows a lot of promise but there are a few problems.

      – Offset – the two channels are offset on the display around the config button so they are not time aligned. This on the Kindle Fire 5th gen. However Galaxy note 4 (6.0.1) is fine!

      – Stopped updating after a minute or so on the Kindle Fire

      – The dialog for the number of points comes up in a strange place – minor I know :)

      – Is it possible to turn off channels still? I can’t see one – I liked that when I am using just one channel.

      – ABuffer mode on 240v mains seems to toggle between useful and no display. Not sure why but the autoranging buttons dont seem to do much in buffer mode.

      – I’d love to be able to graph the maths display function output too…

      I’m also seeing that after quiting the app, the moosh keeps flashing once a second – and I cant reconnect from another device – until I turn bluetooth off on the device. It seems to leave a connection running even though the app has gone. This on a Kindle Fire 5th gen and the galaxy note 4. This does not happen if I manually hit the connection icon to disconnect before quitting the app. Actually I found that going to the “recent apps” and nuking the app does seem to close the connection, so I conclude that hitting “back” from the connection screen does not close the app, but just background it.

      And a few times I get “Connection failed. Status: 133” and no device can scan or connect although the 10sec blip continues.

      And I just got a “Initialization failed. Status: -1” (never mind the spelling mistake s/z/s/) can you tell me what that means?

      Sorry if that all sounds like a whinge – its not meant to be, but feedback from a generally very happy customer!

      Cheers.

    • #10228 Reply
      Anonymous
      Guest

      If Paul doesn’t mind, I will just add my quick feedback on graphing here. Downloaded 16 June 2016 from playstore LGL22C wifi only cell phone with android 5.0.1. Had to reboot phone to install firmware into meter (may have been my operator error).

      The good news is I can now get in and out of buffer mode on a phone without the menu button. However, the bad news is some graph features still have issues. My setup was the infamous unfiltered full wave rectified sine wave into V and C (approx 9Vp), 4000Hz, 256smpl, 60VDC scale, internal temperature for the other channel.

      Pressing the CONFIG button (nice) and turning CH1 Autorange off: Pinch and zoom left vertical scale changes temperature axis. Turning CH2 Autorange off: Pinch and zoom right vertical scale changes voltage axis. It appears you don’t have to pinch exactly over the scales and I found it easier to pinch in the plot area. Drag and release on the vertical axis positions the signal plot. All very nice. Pinch and zoom horizontal (time) appears to have no effect. This would be nice. I could find no way to display only one channel. This is pretty important. Turning Autoscroll off, there is no Refresh button. I’m not sure how useful this would be in non-buffer mode.

      Buffer Mode on, weird things happen:

      With autoranges on and autoscroll on, the internal temp plot is clear at the top of the display (practically off the display) with no way to move it down. The rectified sine wave plot is displayed for about a second, then that plot and scale disappear for about a second, repeat. This “flickering” is annoying. The internal temp and scale appear to always be displayed and does not flicker. Also, every few seconds, the internal temperature plot in degF goes from roughly 70 to 294. Interestingly enough 294 Kelvin is 69.5F.

      With autoranges off and autoscroll on, the voltage display scale changes from 9VDC to -83V. yikes! Turning autoscroll off, the voltage scale and the signal plot disappear. When these strange graph scales occur, if I exit the graph, both the internal temp and voltage DC display OVERLOAD. Sometimes it will self correct and sometimes I have to exit the meter and get back in. —-Duane

    • #10238 Reply
      lynette7530
      Participant

      yea, I noticed the graphing mode is glitchy in the latest.
      Especially when it comes to buffer mode (which I can now use): it goes into this weird blinky state and I can’t see to see ch 2 being drawn (at least in any form of consistency)

      Also I have not figured out how to turn off one of the channels.

    • #10258 Reply
      Anonymous
      Guest

      Now some observations on logging. Looks like the variations in logging values that I was previously seeing has been greatly improved. I ran a few tests on 3AA battery voltage on one channel and 1.8K resistor on the other channel and the values seem solid. Again, I cannot attest to the accuracy of the values because I do not have a precision reference, but the logged values are very consistent now. Worst case value for voltage or resistance was +/- 0.06% from the average. Also, I noticed there were no early logging timestamps.

      However, when I tried to log all night, it only logged for the first hour and a half, then stopped logging. I restarted the logging in the morning. This time, I periodically watched for the LED blinking pattern for logging. When I stopped it after several hours, I had over 90 new files on my SD card with only the header and one row of data in each of the first 89 files and then the last file had hours worth of data. Also, it still has the issue where sometimes you start the logging in the app, but the meter does not log. The microSD card unique LED blinks seem a pretty reliable indicator on whether or not the meter is actually logging, but not whether it is creating multiple files (or at least I am not perceptive enough in LED blink pattern recognition). I think these are old issues.

      Then I wanted to log my house voltage (120VAC) and the meter appeared dead except for slow LED blinks (1/sec). Pressed meter reset, shorted ohm to C, rebooted android phone. Repeated this, but no communication. Removed batteries and reinserted them into meter and then it finally worked. I noticed a couple other people recently with possibly similar issue and maybe more people will give you better clues to help debug this issue.

      By the way, the 120VAC logging values seem solid. This time there were 2 new files, each with a header and measurement values and the second file timestamp picking up where the first one stopped. Simultaneously, I was logging internal temperature on channel1 and the values appear to be in Kelvin even though the app displays degF correctly. I can’t remember if this occurred on previous versions. — Duane

    • #10261 Reply
      admin
      Keymaster

      Hi guys,

      Thanks a lot for this. It really accelerates development. I didn’t push a blog post yet because I’ve been trying to jump on the bugs while they’re still fresh in my mind.

      I just pushed Android beta version 24. Compared to version 23 (from yesterday) it improves graphing behavior. I haven’t had a chance to look at the logging issues yet, I’ve set up some logging experiments to run tonight and will try to look at it on Sunday.

      Again, thank you guys very much. After months of churning code it feels good to be close to finally have measurable progress.

      Best
      ~James

    • #10264 Reply
      Anonymous
      Guest

      Just updating firmware, had to use legacy mode with OnePlus Two, even after it got android 6.0.1 update last week. So, again legacy mode description that says to use with android <5.0 seems a bit off..

      Nothing to say about new build yet, still 5 minutes left :D

    • #10266 Reply
      Anonymous
      Guest

      Sound:on –> instant laughts ;)

      a) “out o-fahrenheit range”
      b) probes in outlet –> “231 THOUSAND 741 Volts” (probably thousand/decimal separator related: “,” vs “.” which are for some unknown reason other way around at otherside of the pond.. Me being in finland/europe.
      c) same as b, but should i be worried when internal temperature is “27 thousand 157 celsius” ;D

      Are those problems mostly on a tts-code or is there something to fix in the app? I cant say if there is already some logic for shortening what will get converted to speech, but most times its a bit overkill to sound out 3-4 decimals when measuring something like mains voltage.. Selectable amount of decimals for tts? Maybe some smooth logic as there is that few second pause between repeats to do it, only decimals that have been stable for over a second would be voiced out? Thats where you differentiate good apprentice from bad ones ;)

      So, sorry for just toying around with features that i probably would never really use, but when an error is in 1000x class, its just too hard to miss ;)

      I’ll promise to use mooshimeter for real work as electrician.. Some day.. Actually even tts might be useful, when i am shoulders deep in a dark recessed ceiling and poking some almost dead device with a test leads.

    • #10269 Reply
      Anonymous
      Guest

      Some additional logging info when I ran it over night again, still on version 23. When I look at the files, I think of the TV series the X-Files :)

      7 new files were created.
      The first 6 files have windows7 file properties of both ‎Created: and Modified: ‎December ‎31, ‎2097. The first 4 of the 6 have the wrong firmware (FW: 1462564395). The SD card had 35 of my previous files, so maybe these were old files, but I do not remember 2097 dates. The headers info is all wrong and the timestamp in each of the files start out at approx 4 seconds and increment by 1 sec (I verified afterwards the logging in the app was set to 10sec). The measured data looks like it may or may not be old data. The last 2 of the 6 files have the correct FW version, with a header, but no measured data.

      The 7th file (LOG042.CSV) has windows7 file properties of ‎Created: December ‎31, ‎2097, ‏‎11:00pm Modified: June ‎18, ‎2016, ‏‎2:07am. There are multiple headers with no measurement data. The firmware version is correct FW: 1466039460.

      So, is it possible, the new firmware modified the old files if they existed? All the file LOG numbers are in sequential order, none missing.
      Independent of the above weirdness, the LED blinking still indicated it was writing to the SD card this morning. Clearly, it wasn’t. So that is no longer a reliable indicator for me.
      — Duane

    • #10303 Reply
      admin
      Keymaster

      Ville: Thanks for the info – can I ask what country you’re in/your phone’s language? I suspect some TTS issues have to do with the Android locale. The app is grabbing the default text to speech converter on whatever platform it’s on, which may behave poorly when fed text that I only tested on the English TTS converter. I am a dumb American and speak only English.

      Also, good idea with being able to set the number of significant digits to read out in TTS. I think I will add that as a dropdown to global settings.

      Regarding the “,” vs. “.” separator: I’ve confirmed that this does have to do with the phone’s locale. European locales by default format decimal points as commas. So when you were measuring, you were 231.741V, not 231 thousand V. The Mooshimeter is not rated that high :)

      Thank you!

      ***

      Duane: I’ve found a couple of subtle issues in the SD card logging in the beta firmware (a lot of it thanks to your help!).

      First: The way the logger is set up in your firmware, 1466039460, it creates a log file as soon as an SD card is inserted and writes the header rows. If/when the user sets LOGGING:ON, then sample rows are written. This is a behavior I’m changing, and it may explain some of the extra logfiles.

      Regarding the 2097 dates: this is a weird artifact having to do with the conversion between FAT timestamps and the Mooshimeter’s internal time format (epoch time). FAT timestamps can only represent times after 1980, but zero epoch time starts at 1970, so the conversion between the timebases fails and gives a FAT timestamp of 2097 (which is the maximum FAT timestamp, 2107, minus 10 years). This is easily fixed though… I’ll plug it so that uninitialized time will give a timestamp in the 80s.

      To answer the question “So, is it possible, the new firmware modified the old files if they existed?” – no, the meter is not equipped to edit files, only append to the end of files.

      I’ve done some logging experiments myself since Saturday and found a few issues – two meters logged data perfectly at 10s logging interval for a few days, one of them choked after 12 hours or so. The one that choked had a 128MB no-name SD card, the ones that were successful had 4GB and 8GB no-name SD cards. I verified it was a watchdog reset, which means the firmware stalled somewhere. I’ve set up an instrumented logging stand to catch the next watchdog reset, I expect it will shed light in to some of the flakiness.

      More soon, thank you again for the info. Best
      ~James

    • #10321 Reply
      Anonymous
      Guest

      OnePlus Two / OxygenOS 3.0.2 / android 6.0.1 / cant find tts-version, but out-of-box google stuff..
      App 1.0.24 (1849) / fw 1466126223

      Locale set to finnish(suomi), does not matter if tts-language is finnish or english(us), mooshimeter speech seems to stay in english.

      If there are three digits after decimal-COMMA, tts would say “thousand” at comma.

      Also if there are four digits after comma (at x,1000 – x,9999 range), tts separate it to two numbers with little pause between and results would be like “one [pause] five thousand three hundred eighty seven volts” for AA-battery. In x,0000 – x,0999 range its a bit different, it goes like “zero ou ou three two volts” (leads off etc) and there are no pauses. As i tested these with a pile of empty batteries, i’m pretty sure there was some exception at some point, but cant reproduce it now :D

      If i set phone locale/language to english(us), decimal comma changes to decimal point and tts would say “point” at it instead of “thousand”, so its probably googles fault and mooshimeter-app does everything like it should. So, quick fix: user selectable decimal separator? Or even better, it would only be used for handing over numbers to tts.. Point even sounds better in numbers and some (most?) finns use it in spoken language any how.

    • #10358 Reply
      admin
      Keymaster

      Thanks Ville, very helpful. I put it on the task list to override the decimal separator. I’m going to investigate changing my own phone’s locale so I can see what European users see.

Viewing 10 reply threads
Reply To: FIrmware 1466039460
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.