Topic | Firmware Update Issues

Home Forums Mooshimeter Support Firmware Update Issues

Viewing 6 reply threads
  • Author
    • #2295 Reply

      Hi there,

      Please forgive me if there’s a note somewhere saying it hasn’t been implemented yet.

      I’ve tried to update the mooshimeter firmware from 2 different Android 5.0 devices: Nexus 4 and Nexus 5. Both devices have given me a toast message “OAD not available on your BLE device.”

      Is this a hardware issue with my phones or is it not yet available in Android yet?

      Thank you!

    • #2305 Reply


      that feature is not jet implemented on the Android app, as far as i know.


    • #2312 Reply

      I see the same on the Nexus 5.

    • #2324 Reply

      I received three meters today (in Canada), and inadvertently did a firmware update on two of them while connecting with the app (on a Samsung S4 (Android 4.4.2)).
      I downloaded the app today (Feb 17) from the Google Play store, with the following specs:
      Updated 16 February 2015, Size 1.1M, Installs 1-5, Current Version 1.0.5

      There were no issues with the app installation.
      The original firmware version on all three was Build 1421369173.
      The two updates went to Build 1418004830. See the screenshots here:

      The first screenshot shows two of the meters waiting to connect. The top meter is the original build xxx9173. The bottom meter has the “updated” firmware xxx4830.
      The second photo shows the firmware update screen I inadvertently got while connecting to two of them (at different times). I tapped the “Start Programming” button and it went through the process smoothly on each one, taking about 6 minutes each time. I got to the firmware update screen by continuing to hold the probes together (after getting out of hibernation), while tapping “Connect” to load the interface.
      I don’t know what the build numbers mean though. I thought that they should increment higher with each successive version. I left the third meter un-updated until I’m clear about what the firmware versions are.

    • #2337 Reply


      received the device the other day and haven’t been able to update the firmware, too.
      The App downloaded from Google-Play doesn’t even show the option to update the firmware, but it shows the build-version of the device.

      The App downloaded from the given link in the box does include the option to update the firmware, but only gives the above already mentioned message “OAD not available on your BLE device.”. This App doesn’t show the build-version of the device, instead it shows the hardware adress.

      Device is a Nexus 5 with Android 5 installed.


    • #2358 Reply

      So if what R.H. says is true, then it seems like the 2 Nexus devices really can’t do a firmware update.

      I tried to tie the leads together while waking the meter up from hibernation and hit “Connect” using 1.0.5 as per R.H.’s post. I was never prompted for a firmware update via the App. It goes straight to the display screen.

      James, do you have any ideas on that?

    • #2359 Reply

      I also kind of wish there was a real login system so I didn’t have to mistype my name there…

Viewing 6 reply threads
Reply To: Firmware Update Issues
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.