Topic | Firmware Update Troubles

Home Forums Mooshimeter Support Firmware Update Troubles

This topic contains 19 replies, has 6 voices, and was last updated by  Ron 11 months ago.

  • Author
  • #14049 Reply

    Eugene W


    I am having a problem with the new firmware update. The firmware was downloaded, then uploaded. After reopening the mooshimeter app the upload started again and froze mid upload. I then closed and reopened the app. Now the firmware is not updating at all. I’ve close and opened the app. I’ve redownloaded the app. I’ve taken the batteries out of the mooshimeter as a “reset”. ANy suggestions?

    Thank you for your time.

  • #14053 Reply


    Hi Eugene,

    Common issues are listed here:

    Are you using iOS or Android? Some Android phones have an issue sending firmware uploads. If you have access to an iOS device (eg. friend’s phone) I recommend borrowing it for a minute and trying from there.

    The other most common issue that causes firmware update failure is a low battery. Could that be the case here?


  • #14126 Reply


    I have a similar problem after downloading update. App 1.08 FW1470628829
    It says meter found but when you try to connect you just get spinning wheel no connection. IPhone 4s and 5s. App reloaded and new batteries.
    I just got this meter the other day and was working fine until update.

    Any ideas?

  • #14252 Reply

    Mathieu Auger

    Exact same things that post #14126

  • #14286 Reply


    Well I see I’m not the only with the same issue and no solution.
    What gives?

    Nothing like spending $120 for something that doesn’t work after update.

  • #14406 Reply



    I recently updated my 5s iphone to IOS 10.0.02. After the update the mooshimeter started working again. Still not working on my 4s phone but haven’t updated yet. Hope this helps anybody else having trouble.


  • #15026 Reply


    Same problem. Dead Mooshimeter. New batteries. New phone – Samsung Express Prime running Android 6.0.1. Just downloaded the app. Upon connecting it told me there was a new update. I followed the steps. It said it was programming the device and the LED rapidly flashed. When done it rebooted. Now it won’t connect and says “Bootloader – Invalid firmware – Rssi: -37 dBm”. Multiple tries with the same result. I have tried removing the battery and resetting the device.

    Up until this point I have been very pleased with the meter. However, if there is a problem with the update we should have been warned. I do not have an IOS phone. I now seem to have a $120.00 BRICK. I AM NOT A HAPPY CAMPER!!!

    I hope someone can give me a solution soon.


  • #15027 Reply


    Update. I am not quite so unhappy. I went out to my car to get my old phone, ASUS Zenfone 2E running Android 5.0.1, To see if I could load the update from it. When I turned it on it found the meter and connected. I turned it off and tried the new phone. It connects now, too. Somehow the meter reset itself. It says it is “Mooshimeter V.1 – Build: 1477971088 – Rssi: -38 dBm”. I have no idea if this is the new firmware or not.

    Information, anyone?


    • #15030 Reply


      Mine has that same firmware.. And as far as i know, that should be the latest (maybe even beta)

      Most connection issues could be fixed by (force) closing the app.. In my oneplus2 its enough if i swipe mooshi-app off from recent apps list.

      Also resetting your mooshimeter by pressing the button beside memorycard slot should help (but then it would appear as bootloader for a while).

      If repeating those would not get you anywhere, try to get to firmware update and try it with legacy-mode. Updating might take ~10 minutes, but after couple tries you would know that you are really screwed.. Or at least should try again with other phones.

  • #15032 Reply


    Hi Alan, Roy, Mathieu,

    Very sorry for the trouble. Here is what I think is happening, and I am expanding the “Android Service Discovery Bug” section of the support wiki because I’ve seen this happen with some other customers who contacted the support email.

    What I think is happening is that the firmware update is successful, and then one of two things:
    1. The phone is caching the services advertised by the meter, making Mooshimeter in “application” mode appear as a meter in “bootloader” mode. To get around this issue, reboot the phone after completing the firmware update.

    2. After downloading new firmware, the meter reboots. After a fresh reboot, the meter is in bootloader mode for 5-8 seconds. It might be that some users are reconnecting while the meter is still in this 5-8 second window and not leaving enough time for the meter to jump in to application mode. You can tell when the meter is in bootloader mode because of the LED blink pattern – in bootloader mode, the blink is 1 second on, 1 second off.

    Sorry again for the trouble, I hope this helps. Let me know if the issue persists.

  • #15194 Reply


    Using Mooshimeter DMM-BLE-2X01A with HTC One (M7), Android v5.0.2.
    Thanks for the advice about rebooting the phone after the firmware upgrade, seems to work now. I was getting very frustrated with the “Invalid Firmware” message… no matter how many times I reset or reloaded fast vs slow. That bit of advice should really be included with the meter, hope this can be fixed in a future update. Android users shouldn’t have to find a friend with an iPhone.

  • #15199 Reply


    Hi Sam,

    Glad you found a solution, sorry for the trouble. Please let me know here or by email if you encounter further issues.


  • #20115 Reply

    Matt Trask

    My Mooshimeter has ceased to work – it just constantly wants to update to the same version it already has. Nothing I’ve done has helped it become an actual meter again. Suggestions?

  • #20121 Reply

    Roy A Kesmodel

    Mine had the same problem with the latest update with Android (constantly ungrading, unrecognized firmwre, etc.). After many tries I finally took the batteries out, polished and bent in slightly the battery terminals and replaced the batteries with fresh ones. After the Mooshimeter rebooted itself I could connect. No reflash needed. Both old batteries were at 1.3 volts, so I don’t know what was going on.

  • #20133 Reply


    Measuring cell voltage, without a load, makes no sense. Put a small load (20 Ohms e.g.) to the cell when measuring.

    Regarding the update loop, it can be caused by empty cells, but there is also a problem with the android app, seems a caching problem. Kill the app completely from the memory (using the task manager, clear the cache), then start the app again.

    I’m using my mooshimeter for years now, I run into such problems many times. It’s a very good tool, but it’s still beta, there a many small issues which the user have to know.

  • #20140 Reply


    Having the same problem as Matt Trask.

    Tried uninstalling app, reinstalling. Then tried new batteries, reset meter, uninstall app, reinstall app, redo firmware update and it’s back in action!

  • #20152 Reply


    Thank you James for you link.

  • #20250 Reply


    I had a similar problem. I replaced batteries, did blue-tooth on/off, remove/install software, bluetooth on/off etc. I tried from two devices running android 5, one intel and one media-tek hardware and the mooshimeter would program ok and then remain in the hardware bootloader with 1 second led flashes. I was ready to give up after a several days of this and then found a phone with android 8 and everything programmed ok, my mooshimeter is working again.

  • #20957 Reply



    the dc viltage keep jumping despite zeroing. any advise

  • #20962 Reply



    I installed latest firmware on my android, there is issue the voltage dc keep jumping when probe not in contact.

    i have reinstalled the apps and restart my phone, problem still persist.

Reply To: Firmware Update Troubles
Your information: