Topic | Initialization failed:status 1

Home Forums Mooshimeter Support Initialization failed:status 1

This topic contains 35 replies, has 7 voices, and was last updated by  Jan Harkes 5 months, 1 week ago.

  • Author
  • #16867 Reply

    Brett Richard Johnson

    I carry two mooshimeters most of the time. Today I can’t get either to work. I can see them during scan. If I connect to either one, I get the error initialization failed ; status 1. Both meters worked fine until as recently as the last day or two. I have a new Pixel phone with android 7.1.2 . I think I got an update, maybe on the 3 so that may have something to do with it. Anyone else experiencing something like this?

  • #16919 Reply

    Roland. Heinl


    I had the same issue.
    It was working with a newer Android 7.0 Version and stopped
    a few days ago.
    But it was still working with an older android version and smartphone.

    I had the same gueswork like you.
    I tried a few setup changes an couldn’t solve the problem first.
    Now I decided to try a few hardware changes.

    I didn’t have a SD card in the slot yet. So I put a 16 GB SDHC card in the slot, made a reset, connected again and now it is working.

    Hope it’ll also help you

    Good luck

  • #17470 Reply

    René Arts

    I am experiencing the same issues with Android 7 on my Lenovo P2.
    Tried replacing batteries, reinstalling the app.
    I feel it should not be necessary to place a SD card to be able to properly use the Mooshimeter, which I really love working with, though currently I am heavily disappointed by these issues!
    Has anyone already found another (temporary) workaround?

  • #17798 Reply

    Brett Richard Johnson

    Yup…. Nope… still struggling with this. So bummed. I actually went and bought a regular multimeter today because I couldn’t get either mooshimeter to work. I am pretty sure it happens when my phone and I walk out of the meter’s bluetooth range but once I do that, I can’t connect to either moosh so does that seem like a problem at the phone end, rather than just with one meter?
    I have a bunch of other bluetooth devices, mostly speakers and headphones, and they don’t seem to die if I walk out of range. They just go to sleep and wake up when I get back. Mooshimeters become zombified and to recover one, I seem to have to reload the firm ware in most cases. This sort of relegates my mooshimeters to the bench for now and I’ll have to take my new dumb meter for field work.
    working in green bush
    lights, relays, unlabelled wires
    no moosh, much bummage

  • #17831 Reply

    René Arts

    Mine does work from time to time, though I haven’t figured out the condition(s) which triggers it to connect again. The indicator LED is still flashing every 10 seconds, and flashes every second (like while it is connected) while the app says it is initializing.

  • #18198 Reply


    I have the same problem now, was working great, can pait under Bluetooth, but in the app it’s always the unplugged icon and initialization failed -1

    Seems there is no app update, no firmware update. Anything I can do?

  • #18404 Reply


    I’m having the same problem. Only reprogramming with bootloader will bring it out of the error – 1 zombie state. If I continue trying to connect I get a connection failed status 133 and won’t be able to attempt a connection again until I force close the app.

  • #18588 Reply


    Same problem here, using Pixel XL. Can’t get it to connect most of the time, have tried switching BT on and off, restarting the phone, all that. Very irritating.

  • #18617 Reply


    If you want to dig in deeper, here are instructions how to build and get debug output of the app:
    (But please open a new bug report then).

  • #18655 Reply



    I join up the people here, I bought a mooshimeter 2 weeks ago, I used it for about a dozen of time. The praticality of the device falls appart if you have to restart and reload the firmware to make it work again…

      I’m currently on a samsung galaxy A3 and the only ways to manage to pull it out of failure like “error -1” or “status 133” is to reload the firmware.

    If the devs are unable to provide any stable firmware/apps whatever reason there is.
    I would be nice to know the procedure and which version of apps and firmware that are considered as really stable.

    Thanks you

  • #18675 Reply

    René Arts

    Since I was still experiencing issues, last week I re-flashed the firmware on my mooshimeter (just normal OTA via the app). Had to use the slow/old method BTW to let it succeed. Though the version is still the same (there was no update, just reflashed out of curiosity), I have not yet to encountered a failedstatus -1; the meter seems to be working fine and reliable again. Problem is a few days after the firmware flash I also received an OTA Android (security patch) update, so I’m not sure whether reflashing is a reliable method. Maybe one of you guys can test it as well?!

  • #18676 Reply


    I just had the same Issue (but “Initialization failed: status -1” exactly).

    I mainly use my S7 Edge on Android 7.0 with Mooshimeter App v1.0.34 (2115), firmware 1477971088, and had logging running over night. It’s the first time I had this problem and firstly I thought It was maybe because I changed the Log interval from 1s to 10s after ~3h off logging (-> first time this error, first time switched this value while logging).

    I tried ~10 times to connect, meanwhile closed the app, no success. Then I switched to my second device (Note 4 on Android 6.0.1 – same App version) and there, I firstly had the same Issue but I think on the second attempt the app initialized correctly. After that (closed the app) I could connect with my S7 Edge without error…

    So maybe this Issue is related with Android 7? Just wanted to write this quickly down here, maybe it helps others. I’ll keep watching this. :)

  • #18704 Reply

    René Arts

    I’m running Android 7.0 btw, with security patch level of 01-07-2017, still running fine after the firmware flash.

  • #18973 Reply


    Had a log running the last hours. Connected, stopped logging, clicked “load available logs” … no logs in list but message “Waiting for log data” for minutes and mooshimeter status led was disconnected with SD present. (like I described yesterday here ).

    Then trying to connected/closing the app/reconnect/closing app/disable-enable Bluetooth/…. every time “Initialization Failed. Status: -1” and sometimes there was written something like “no device detected”, although the mooshimeter was shown on top with ~ -60 dBm signal strength.

    Then after like 10 or 15 times a new message appeared “I don’t recognize this device… aborting“. After that I could connect to the meter. Like yesterday, the app itself set values sampling to 32smpl and log time to 10s by itself (was 265smpl and 0s before).

    So connected and next try reach my log, load available logs -> no message, no logs, meter disconnected (with SD present) -> “Initialization Failed. Status: -1” …

    This is now starting to really annoy me! :(

  • #19017 Reply


    I tried to use my meter today and had the same symptoms as Harry. This is most inconvenient.
    I’m running Android 7.1.1 on a Moto Z Play

  • #19018 Reply


    Yesterday I had the same issue again, this time tried to document nearly every step via screenshot, since there seems no error log available (this may be a good idea, wouldn’t ;) ). Minor or less the “procedure” was the same as written above.

    You can look at them here (20 screens, look @ date/time):
    Samsung Galaxy S7 Edge, running Android 7.0 (security 08/17)

    Hopefully this helps. I know James is very busy and alone with this project atm, but this had to be fixed asap! Or is my device (and therefore Henrys too) maybe defective?


    PS: One day later, everything worked as normal and I could receive the logs via app… but that’s not a acceptable status!

    I’ll try the next times with Android 6 device…

    • This reply was modified 9 months ago by  Harry.
    • This reply was modified 9 months ago by  Harry. Reason: Robinson Route
  • #19021 Reply


    I should reiterate my problem, I haven’t been able to connect at all. It worked until recently, but now all I get is the “Initialization Failed. Status: -1” message. I have no other phone to test this with.
    I’ve been really impressed by this little device since I got it last winter, but in my mind it’s been downgraded from “useful tool” to “broken toy”. A great idea, but the software needs to be as robust as the hardware.

  • #19072 Reply

    Thomas Vance

    What’s going on with this issue? Haven’t been able to connect with my meter since I tried some logging. All I get is the “Initialization Failed. Status: -1” message. Android 7.0 droid turbo 2.

  • #19095 Reply

    René Arts

    Did all or one of you try to reflash the firmware? I still haven’t had a single problem afterwards, I have been using/testing it almost daily.

  • #19166 Reply


    same issue for me either status -1. I got the Mooshimeter a few days ago, and used it study batteries discharge, logging Amp? volts of batteries discharging in calibrated resistor.
    I have place a 16M micro SD card inside, logged and download the Measures over a few hours, time of discharging.
    It used to work fine with moto C and androïd 7, and finally while reconnecting to check the discharging process got the status -1 error;
    I so tried to connect with an ipad and it works with it while it doesn’t work anymore with the moto C. But I don’t like the Apple app, display doesn’t rotate, display is cut on the right side, download logs doesn’t record the file locally but generate an email to send the file attached.
    I then tried an older Cell photo Motorola with Android 5. It then worked a couple of times, then end in status -1 error also.
    Only the Ipad Apple App seems not affected by this bug and continue to work.

  • #19167 Reply


    I have now reloaded the mooshimeter firmware and it works again with androïd… not sure for how much time though ?
    But when I watch the video showing how to reload the firmware the author says there are bugs in the bluetooth pile in android they have no control over!
    It probably explain what happens, and why IOS still work with the Mooshimeter while androïd doesn’t. Seems better to use IOS celle phone with the mooshimeter though. I’ll have to get back my old Iphone3 working for it.

  • #19174 Reply


    Hi guys,

    I’m sorry I’ve fallen behind on the support work over the last few months. Besides the Mooshimeter I do product development under contract and I had a couple of contracts flare up at once. I’m over the hump now and turning my attention to these Android connection issues. The Android connection issues have been a sticky problem since the product launched, but from this thread and some emails I’ve been getting, something seems to have changed to make the problem worse.

    I’m going to put together a beta version of the app built around the SweetBlue Android BLE library instead of trying to hunt down and fix these issues one by one. Yes, Android BLE is so bad that there’s a cottage industry in finding workarounds. I’ll try to get this beta version out by next week, and we can see where we stand with these bugs then.

    Thank you

  • #19178 Reply


    I had the same issue:
    “Initialization Failed. Status: -1”
    May be it happens during logging and nod depend from phone. Because i use 3 phones (Samsung A3, Moto G3, Iphone) and no one connects.
    I hope you fix it in next update.

  • #19183 Reply


    Have the same issue with one of two multimeters with my Pixel XL, IPhone’s seems to have no issue with connecting.

  • #19192 Reply


    Hi guys,

    Thank you again for all the datapoints.

    I integrated the SweetBlue library and have been testing the new version of the app (version 37) on a few different phones, including an Google Pixel with Android 8 installed. So far the behavior is good.

    I’ve released version 37 to beta testing. You can join the open beta here:

    Please let me know if this improves behavior for those of you who have been experiencing initialization failures. You can give feedback here, through email, or through the Android beta program.

    Thank you!

  • #19201 Reply


    Hi James,

    Thanks for the update it seems to work a lot better, but I’m still having a minor issue with setting the name, seems there is some garbage when either reading or setting the name:

    padding chars for name?

    On another note, we are using the unit to measure V and A on a CAN bus device in a car(Awesome device btw :)). This morning when I took out the unit it was blinking a fast red and it had not logged anything, does this mean the unit crashed?

    Is there a manual for what the different lamp mean?

  • #19221 Reply


    I’ve just had the same error (“initialization failed”). I tried connecting lots of times, and also tried rebooting my phone, to no avail. When I pulled a battery out of the meter and re-inserted it, it then worked the very first time. I’ll try that beta version of the app.
    I’m on Android 7.0

    • This reply was modified 7 months ago by  GregS.
    • #19238 Reply


      The problem happened again, but this time removing and replacing a battery didn’t work. The beta app is working – thanks. Note that sometimes the app takes quite a long time to connect, but it always connects.

  • #19258 Reply


    Before the app update I hat the problem very often. I was able to reduce the failure by deconnecting the mooshimeter before I leave the app. But sometimes I hat the failure and had so reflash the firmware to get a connection again.

    Now after the Update the problem didn’t occur again. I tried to get the failure again by not disconnecting but it works.

    Great Job James, thank you.

    • #19279 Reply


      Hooray :) Thanks for the update

  • #19312 Reply

    Martin Mueller


    installed the beta just now on Galaxy S7 edge and Pixel 2 – no luck. “Status: -1” in both phones. Used to work until a couple weeks ago on the S7, which had at least one system update before. W/o the update both phones didn’t connect, Pixel said “Status 133”, S7 just failed.

    Very sad, liked the Mooshimeter quite well.

    Please keep researching this.


  • #19362 Reply


    Hi Martin,

    Sorry I didn’t respond before the holiday. Thanks for the feedback. Status: -1 is a timeout. Status 133 is a generic “GATT ERROR”, which usually means something’s become screwed up inside Android’s BLE library.

    I’ve tested the beta on a Pixel 2 and a Galaxy S6, so I’m optimistic it should work for you. Are you still stuck or did it start working again after a reboot of the phones and meter?


  • #19365 Reply

    Jan Harkes

    Android app, even beta, was unable to connect on my Pixel 2 XL with Android 8.1 (December patch level). But I knew the meter worked because it worked fine on both my old Nexus 6 phone and a Nexus 7 tablet.

    Tried debugging the app, but found nothing that indicated anything was wrong, just always failing to connect. Read a lot of posts on the Google product forums and one looked interesting.

    Someone claimed that uninstalling the ARCore update and rebooting fixed his Bluetooth issues so I gave it a try and…

    Now I can talk to my mooshimeter with my Pixel 2 XL.

  • #19367 Reply

    Jan Harkes

    And to add to the complete randomness, overnight the ARCore update that prevented me from successfully connecting got reinstalled. I guess on the Pixel it is a system app so it didn’t really get uninstalled and I have automatic updates enabled. But… BLE is still working and I can still connect to the Mooshimeter.

  • #19374 Reply


    Wow that is strange. Thank you for taking the time to document it.

    I suspect the ARCore update may be something of a red herring since this is the first I’ve heard of it. Sometimes the Android BLE stack just gets really confused and doesn’t sort itself out until a reboot, so maybe the updating process just forced the reboots at opportune times.

    Thanks for the details and let me know if you figure out anything else.

  • #19377 Reply

    Jan Harkes

    I agree that it is very strange and quite possibly unrelated. I know I rebooted my phone several times because that seems to be pretty much the first step to debugging these annoying Bluetooth issues. Only after I noticed that my Weber grill thermometer was also unable to get a connection going did I start to suspect some system-level software update that got installed because I knew the thermometer worked in early December. And yes, that one also started working again after the reboot.

    This is a link to the post (by Mike Zalansky) that pointed the finger at the ARCore update.

    Except for the two emails following up on the one above, the rest of that thread is pretty much useless. But you may very well be correct and the uninstall/reboot cycle just happened to unwedge the BLE stack at the right time for me.

Reply To: Initialization failed:status 1
Your information: