Topic | iPhone won't connect

Home Forums Mooshimeter Support iPhone won't connect

Viewing 8 reply threads
  • Author
    Posts
    • #16215 Reply
      Mike Raven
      Guest

      Issue: Mooshimeter app hangs on attempt to connect.

      Details:
      . Mooshimeter iOS App 1.10
      . iPhone 4S running iOS version 9.3.5

      Symptoms:
      . Scan process finds the meter, populates the device list, shows good
      signal strength.
      . When the device is selected, the two halves of the connection plug
      icon mate, but stay grayed-out.
      . The spoked spinny progress wheel spins, forever.

      Attempted remedies:
      . The usual: force-quit, Bluetooth disable-enable, power-cycle the phone,
      Delete & reinstall the app, reset the meter. Etc.

      Oddities:
      . Things work fine when the Mooshimeter is accessed via the Android app.
      . The iOS app actually DID work initially, for several hours!

    • #16222 Reply
      admin
      Keymaster

      Hi Mike,

      That is quite a strange symptom, especially if it’s working well with the Android device. I can think of two possibilities:

      1. The iOS device is saving some kind of pairing information for the meter that it shouldn’t be. If you go to settings->bluetooth and see the Mooshimeter listed even when it’s not connected, delete the pairing information by pressing the little “i” next to the Mooshimeter’s listing and hitting “forget device”. Then try again.
      2. It may be that the Android device is never disconnecting from the meter even when it says that it is. If it’s in the room when you are trying to do the iOS connection, is it possible to turn it off and try again?

      Let me know how it goes, best
      ~James

    • #16289 Reply
      Anonymous
      Guest

      Thanks for the suggestions, James. Alas, neither of them is helpful:

      1) The Mooshimeter pairing doesn’t appear in ‘settings->bluetooth’. I actually tried wiping out all the pairings that DO show, to no avail.

      2) The Android device I connected to in my troubleshooting efforts is now in a different state. As in state of the Union. It’s two thousand miles distant. If it’s the culprit, kudos on the Mooshimeter’s range!

      Additional information: I can also connect successfully using an iPad running iOS version 10.2. Unfortunately, the one compatible device I actually own still won’t connect.

    • #16292 Reply
      Anonymous
      Guest

      I’ve often had a similar issue with my iOS. It’ll hang, and it’ll eventually end up wanting to update firmware with the same firmware. Tried same remedies, including toggling bluetooth on and off and pulling batteries out of meter didn’t work. Next day, it works fine again.

    • #16297 Reply
      Anonymous
      Guest

      Additional additional information:
      I’m ALSO able to access the meter using the Mooshimeter-PythonAPI (though the output of ‘Example.py’ is markedly different from what’s shown on the ‘Talk to your Mooshimeter…’ page.) For what it’s worth, I’ve got that working under python 2.7 on a MacBook Pro running OS X version 10.11.2.

      And unlike Ryan’s situation, my iPhone app does not heal overnight.

    • #17410 Reply
      Anonymous
      Guest

      I’m having the same issues – Iphone 7+ latest iOS (may 2017 – 10. 3 . 2 ) I have 64 gig rM free on this phone – no other apps running – no other blue tooth devices around, I managed to get it to connect once for 5 minutes yesterday in an hour of struggling – nothing this morning after 40 minutes.

      I’ve tried new batteries, resetting the mooshimeter, ejecting the memory card etc
      Re setting the phone deleting the app – switching to airplane mode etc etc.

      Within the app – it reports the meter then on the page displaying measurements it reports. “Loading” but doesn’t. The app then often closes.
      If I scan again the meter has apparently disappeared – then it finds it – but never displaying a reading.

      Frustrating is an understatement.

      We bought the meter for a project where colleagues used it and found similar connection difficulties – and ended up using it with an android phone I think – I dont have anything android and iPhone is the way forward for me.

      In need of a firmware fix – app fix …?

      The app is 1.10 1373
      The firmware is 1477971088

      Has anyone else come up with a solution ?

      Without connecting to the phone it is a useless brick.

    • #17427 Reply
      Anonymous
      Guest

      I’ve come back to it this evening –
      Similar symptoms, but this time when I ask my iPhone to scan, within a fraction of a second the app reports nothing found – repeatedly.

      The mooshimeter is sitting here with the orange led doing a Rapid triple blink, then A pause for perhaps 2 seconds then repeating.

      I just can’t get the iPhone to even see it … let alone interrogate it tonight.

    • #17787 Reply
      Anonymous
      Guest

      Thought I’d come back to see if anyone in Mooshi land was up to helping.

      Sadly not… 2 weeks on, it still hasn’t connected to my phone.

      Is there a guarantee on these things… ? It doesn’t seem to work as any kind of meter.

      Frustrated and defeated…

      Jonathan

    • #17806 Reply
      Anonymous
      Inactive

      See my comments in this thread – https://moosh.im/f/topic/android-ble-connection-problems/

      I need to find my other Android tablet and check it to determined what Bluetooth version it is. I also need to check the Mooshimeter Bluetooth version as well.

      I am starting to suspect that part of the problem is that the Mooshimeter is Bluetooth 4.0 or Low Energy Bluetooth. I recently purchased a Ion Bluetooth Speaker for my son and tried to test it out one of my Android devices that is not Bluetooth 4.0 Low Energy and it was interesting that my Android could not see the Ion speaker at all. While the Bluetooth Spec clearly shows that Bluetooth 4.0 should be backwards compatible with earlier versions of Bluetooth. I think there are non compliant Bluetooth 4.0 devices and/or devices that have firmware bugs in them.

      I would try to reset the Mooshimeter, put it in shipping mode, then wake it up from shipping mode and try to reconnect.

      I found that if the meter was in Logging mode, I would also sometimes have more problems connecting via Bluetooth, not sure why, but seems the Mooshimeter may have been wrapped up Logging too much if I had a fast polling speed.

Viewing 8 reply threads
Reply To: iPhone won't connect
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.