Topic | Issue: Channel 1 parameter changes by itself during logging

Home Forums Mooshimeter Support Issue: Channel 1 parameter changes by itself during logging

Viewing 7 reply threads
  • Author
    • #19768 Reply


      I am currently using the mooshimeter to measure the change in resistance of a potentiometer. I therefore set channel 1 on “resistance”. Channel 2 is set on “internal temperature”.

      I started the logging @ 1 second interval.

      After approximately one day of logging the parameter of channel 1 is somehow changed to “aux voltage”, making all following measuremnet useless. Channel 2 is somehow not affected and keeps measuring internal temperature.
      I repeated the same log @ 10 seconds interval but face te same issue

      What could be the problem?

    • #19769 Reply

      I have no idea, but I just set two mooshimeters to log my bedroom radiator input/output temperatures with ntc-sensors (salvaged from heated floor thermostats, both did show about 40 Kohm at room temperature, so probably 33Kohm@25degC). First one at 10 s interval and other at 1 minute. 125Hz/64smpl (auto) sampling rate.

      How long you actually let it sit before checking it out? Log for a week and screwed at ~24h or log for a day and things went crashing way before that? Did you connect to your mooshimeter while your experiment was going on? I just like to know more, so i could reproduce your setup.. My meters showed 100 and 86 percent for batteries, did you have full batteries to start with?

    • #19770 Reply

      Hello Ville,

      During my first attempt I logged for a week, discovering afterva week that the batteries died after four days. The logging data therefore stopped after four days. when I checked the data I discovered the glitch mentioned in my first message.

      The second attempt was a copy of the first but with new batteries. Here I also had the mooshi log for one week after connecting again. here the same glitch happened after 19 hours.

      I repeated the test again with 10 second interval for 2 days, but here the glitch happened again after one day.

      I am now repeating the test but changed the channel on which it logs the value. Hopefully this will be better.

    • #19771 Reply

      So, i’ll shoot for over 2 days then. If i remember, i check them on sunday.

    • #19772 Reply

      Two days of logging done.

      Meter with 1 minute log rate was ok, 3163 lines, ~52,7 hours. I let it continue, probably check it again in couple of days. Or next weekend, if i forget it.

      Another one with 10 sec intervals gave 5624 lines (~15,6 hours) of resistance readings, before changing to 1,2 V aux. There is error code 460. In the end of log (~19k lines) there was another header, which stated channel 1 were at 300 mV range. No more error codes or other traces of reboots, couple glitches in readings though (might have happened while transferring over bluetooth, haven’t yet tried again). There is 78% of battery left.

      It has something to do with reboot recovery and as such we have two different “problems”. Why do we reboot and why cant we recover nicely?

    • #19777 Reply

      Hi Ville,

      Regarding recovery from reboot: I looked at the code, and it seems that while the channel 1 and channel 2 settings are stashed and restored, the auxiliary channel setting was not. This is why after the reboot, you were connected to the aux channel but with the default setting (aux voltage DC). I’ve patched this in firmware and will release it shortly. Thank you for finding another edge case.

      Regarding why we reboot at all: Honestly I’ve struggled with this a lot and I don’t have a great answer. It’s quite hard to diagnose because it only happens once after a few days. It seems to happen in the SD card initialization period when the meter is waking up to take a reading, but that’s about as far as I’ve gotten. So far, making reboot recovery robust has been a good time investment compared to the weeks I spend chasing flaky errors.

      Thanks again, best

    • #19784 Reply

      Hi James,

      Any idea when the new firmware will be available? For a project I need this issue to e solved.

      Hope to hear from you.

      Kind regards.

    • #19868 Reply


      It’s been a while. Same bug just bit me. You never released that fixed firmware?

Viewing 7 reply threads
Reply To: Issue: Channel 1 parameter changes by itself during logging
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.