Topic | Issues Connecting with Meters

Home Forums Mooshimeter Support Issues Connecting with Meters

Viewing 2 reply threads
  • Author
    • #4156 Reply
      Jake Connor

      I’m having issues connecting to a pair of meters, hopefully it’s an app issue so here’s the app info:
      Android App v 1.0.13 (335)
      Sony Xperia Z3

      My first meter is listed in the android app, however when I try to connect, it takes about 5 seconds and then crashes, and supposedly submits a crash report. When I reload the app, the meter is once again listed.
      rebooting my phone, disabling/enabling bluetooth, resetting the meter had no effect, however I can connect using BLE explorer and retrieve some (indecipherable to me) data.

      I was able to connect to this meter using an iOS device and it worked fine.
      Currently on build 1421369173, I’m hesitant to update the firmware given the issues listed below, and that it does work with my colleague’s iOS device.

      The second meter is a little trickier.
      At first it was listed in the android app, however trying to connect would take 5ish seconds before saying it’s unable to connect. Once again reboot, cycling bluetooth didn’t work. The device responded to BLE Explorer with data, I didn’t test connecting with the iOS device (which I don’t have access to for now).

      After resetting it the meter stayed in bootloader mode for a while (neither of these devices seem to stick to the 5-second window), eventually I connected to it to do a firmware update. The update worked, said it was verified, and the meter appeared on the screen again, I connected and tried to change the name (would be nice if the name persisted).

      After “saving” I got kicked out to the main screen, and the meter was listed as “Bootloader” and not returning to normal mode. It stopped being listed for a while, eventually after pulling and reinserting the batteries it appeared in bootloader mode, I installed firmware again, and the meter became stuck in bootloader mode, at build 1435205316.

      Some time later, the meter dissappeared from the app listing again, and is now listed in BLE explorer as an unknown device. LED is still blinking as if in bootloader mode.

      I own a third meter that’s currently on loan to a friend, I’ll try to use that meter with my phone and my meters with their phone early next week to try to isolate the cause, in the meantime is there anything I should try?

    • #4161 Reply

      Hi Jake,

      Thanks for the detailed descriptions.

      Regarding first meter:
      Can you try updating the firmware from your friend’s iOS device? The update process only takes a minute from iOS and is generally more reliable than the Android update process. Your firmware on this meter is from January, the first release.

      Regarding second meter:
      You might be fighting two issues here. A little background: One thing I’m kicking myself over is that in bootloader mode, the microcontroller doesn’t enable low power, so it chews up power pretty quite fast (fresh batteries will die in about 1-2 weeks in this mode). On top of that the bootloader doesn’t check its own battery voltage, so one thing I’ve seen happen is that if you try to update firmware with batteries that are near death, the update will start but will fail partway through, resulting in an invalid firmware image, which then causes you to get stuck in bootloader mode. That might be what’s going on.

      So for both meters, can you try putting in a fresh set of batteries and updating firmware from an iOS device? In theory the iOS and Android update processes are the same, it’s just there’s much less variation between iOS devices’ BLE implementations.

      If this fails you can send your meters to me and I can reflash and recalibrate them manually.

      Let me know how it goes, thanks!

    • #4175 Reply

      A fresh pair of batteries and more firmware updates seems to have worked.
      Oddly on the old batteries the firmware update process claimed to be successful and have verified everything, which is odd if your theory is correct. But I’m glad things are working now. Thanks!

Viewing 2 reply threads
Reply To: Issues Connecting with Meters
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.