Topic | Missing Beep and Precision-Setting

Home Forums Mooshimeter Support Missing Beep and Precision-Setting

Viewing 8 reply threads
  • Author
    Posts
    • #17146 Reply
      Richard
      Guest

      I’m missing the simplest function of an multimeter, which is to beep on an closed circuit (0 ohm).

      Instead there is the voice output (which IS AWESOME btw! – if:

      – there was an precision setting.

      The sensors on the mooshi are apparently very sensitive which leads to a load of noise / constant changing values on the x.th decimal place, although nothing is really happening.
      For me this is confusing when looking at the display, but it is really annoying with the voice output. Because there is constant babbling, with way too much decimal places.

      When I’m measuring for 230V I don’t need any decimal places at all.
      And at the car / computer, I’m fine with with 2 decimal places, I don’t need 5.

      Long story short/ TLDR:
      Please provide precision-setting – and beep feature.

    • #17150 Reply
      Anonymous
      Guest

      Richard, See my comment under your other post (Missing Shunt support). Tasker can easily do beeps. — Duane

    • #17153 Reply
      Anonymous
      Inactive

      Why do i remember complaining about continuity beeper being too slow for actual use? Did we have it at some point?

      So, it would be basically useless, when there is ~half second delay from touch to sound.. And it would be hard/impossible to make fast enough over bt.

      I had to run to my car to get my mooshimeter (yes, it has actually graduated to live with my “real” tools ;) )

      And yes, it is there, in diode drop mode, it does beep. But that delay is more like a full second, for both “edges”. Seems even longer, as you remove your short and whistling just continues..

      But, there is little delay also on Fluke 87.. And it does some indication of bad connection while measuring and generates (yes, very little to do with actual contacts) “chirps” instead of a steady whistle. Which is also annoying, as very cheap and old beepers have an actual current path from battery through measuring leads to beeper and only delay would be from that piezo-element to “warm up” for some milliseconds, so in practice, there is no delay.

      Mooshimeter –> bt –> phone –> mooshi-app –> tasker – path would only make it slower? Or is there anything to do with mooshi-app in that scenario?

    • #17156 Reply
      Anonymous
      Guest

      Ville,
      You bring up a good point on delay time. The best solution always depends on requirements. With some effort Tasker can do everything listed in the original post with several caveats, one of which as you point out is reaction time. Tasker would be great in an automation scenario where you could not only beep, but actually speak instructions to the operator based on different voltages, currents, resistances, etc. If the requirement is lowest delay continuity beep, a piezo buzzer as you describe would be simpler/cheaper/easier. —- Duane

    • #17158 Reply
      Anonymous
      Guest

      Currently my mooshi is measuring my cpu power draw (so I can’t just unplug it ;).
      But I will test the beep on diode drop next time.

      Cannot really imagine that BT is that slow? 1 second delay sounds bad, but maybe I can adapt to it for these few occasions.

      Duane, I don’t agree with you on your other reply / Tasker solution, however I will open a new thread for that.

    • #17163 Reply
      Anonymous
      Inactive

      I did some more testing..

      Sampling settings make quite big difference on that beeper delay..

      That ~1s delay was with auto on both settings and internal temperature on second channel. So 64smpl@125Hz.

      With second channel set to ac voltage and sampling still on auto: 256smpl@4KHz, about half second delay, which is closer to what i remembered and probably what i would have had normally.

      Then, trying to find fastest setting manually, i set 32smpl@8KHz and delay do go down (not that much actually), but then there appears to be even worse problems.. Sometimes beeping stops after just a quick disconnect, but display still shows under millivolt drop. Thats bad, as beeper should be trusted for its sound..

      I’m trying to measure those delays bit better, but it seems that my video editing skills would not produce publishable proof.. Strange stuff happens on my video though.. Set sample rates to 256smpl@125Hz and short your leads –> beeper goes about 1 sec beep, 1 sec pause, 1 sec beep etc.. And then there is really over 2 second delay, but at this time, it is what we were asking for by our settings.

      With supposedly fastest settings (32@8KHz) about half of that beeper delay seems to happen after there is already value of a short on the screen.. So it should be possible to get it faster. Maybe even let beeper have smaller sample size and forced settings for faster sampling when selected, now it is paired with diode drop which works just fine with slower settings, but those settings follow second channel and may be anything..

    • #17164 Reply
      Anonymous
      Guest

      OK Ville, you got me curious. I used 3 different android phones and got drastically different results with the same mooshimeter, same settings 32smpl@8KHz:

      Samsung Galaxy S3, android 4.4 no tone ever. Most of the time I could hear a click sound on short and open. (unacceptable) Speaker works since it speaks when enabled. All phone settings appear to be correct.

      Motorolla Moto E (XT830C), android 4.4.4 tone has 2 second long delay on short and open (unacceptable)

      LG Optimus Zone 3, android 5.1 tone is practically zero delay on short or open (very acceptable) This one was basically instantaneous response time.

      I was certainly surprised by the above results. Any ideas? —- Duane

    • #17168 Reply
      Anonymous
      Guest

      > Any ideas?
      Android 4.4 sucks?

      I tested on my Sony Xperia Z3c with Android 6.0.1 and with 8kHz and 4kHz it is almost instant (very acceptable).
      The lower the freq the longer the delay, for samples I didn’t noticed any (noticeable) influence.

    • #17177 Reply
      Anonymous
      Inactive

      And the results are in.. (averages of ~5 tests)

      Mooshi (app-1.0.34 (2115), fw-1477971088)+OnePlus 2 (android 6.0.1)
      Diode drop / manual 32smpl@8KHz:
      Leads touch –> value on screen: 163ms
      Touch –> beep: 354ms
      Leads off –> beep off: 478ms

      Fluke 87V
      Ohm + beep = manual 600ohm:
      Touch –> screen: 313ms
      Touch –> beep: 75ms
      Leads off –> beep off: 93ms

      These values are not by any means absolute, but should be comparable with each other.. I took video of what was happening with gopro 3 black @ 240fps and tried to do publishable video, but it was becoming so shitty that i just thought to tell you the numbers. I tried to be fast with the probes touching and managed to hear them clicking and even that had a delay of ~40ms (~10 frames) compared to video.. So all my values might be 40ms high, but i’m not touching them to prevent any more mistakes..

      I was quite sure that there were delays with my fluke, but it seems to behave just the way any beeper should.. I have had it sound a constant beep-beep-beep-beep on a bad connection, but could not really reproduce that for a video.. There was little hints of it though and i still believe that it is real.

Viewing 8 reply threads
Reply To: Missing Beep and Precision-Setting
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.