Topic | Mooshimeter connected with PC

Home Forums Mooshimeter Support Mooshimeter connected with PC

  • This topic is empty.
Viewing 11 reply threads
  • Author
    • #2344 Reply

      Hi, because I have three android devices, which all do not meet either the mooshimeter ble or kitkat requirements, and even a new kitkat tablet with bt4 didn’t support ble, i tried setting up a android 4.4 x86 system in a virtual machine and bought a €5 bluetooth dongle (CSR8510). to my surprise it works :-) now i have more time to find an appropriate android device.


      i know this setup was not part of the project, but i just wanted to share my observations in this constellation, or perhaps does someone else still search for an appropriate device to connect. app was downloaded 3h ago from website:

      1. the screen is tilted 90°. can be fixed with a screen rotation app, or maybe is already part of a non-stock android firmware.

      2. i didn’t find a way to switch to the graph view, because this seems to only be possible by rotating to landscape format, not by a button or menu item. is an addition possible?

      3. firmware update fails with message “OAD not available on your BLE device”. is this still unimplemented on android or a hardware problem?

      4. trying to check the app version, i noticed that the “About” menu item does nothing, is this normal?

    • #2349 Reply

      Hi Marc,
      I have similar hardware restrictions and no direct need for more portabillity so I tried my luck with Andy; Android in virtualbox under Win7.
      Unfortunately I was less lucky ;-( (the parsing problem during install).
      Can you please specify your setup so I can get things working too.
      Many thanks in advance.

    • #2351 Reply

      Hi Matthijs,
      my first guess, because of the parsing error, is to check the version of the android x86 image, is it 4.2 or lower? i used “android-x86-4.4-r2.iso” from, then only installed the mooshimeter app via browser. the bluetooth usb stick has to be inserted into the host before starting the vm. bluetooth should be switched on if not already on by default.

      optional is installing a screen rotating app or cursor movement is difficult with the head rotated 90° :-). i noticed that pressing STRG+F10 or STRG+F12 in the vm switches between text and graph mode, so this function can also be used in the emulator.

      i have no experience with virtualbox, i only tested vmware player and read that virtual box should work, but that shouldn’t be the problem here. this might only matter in the way how/if usb devices can be used in the vm.

    • #2352 Reply

      here a screenshot of the graph mode in the vm, mooshimeter connected to a solar panel. y-axis represents solar current.


    • #2353 Reply

      Hi Matthijs,
      my first guess is, please check the version of your android x86 image. the parsing error sounds like you have 4.2 or lower, which does not meet mooshimeters requirements for bluetooth low energy (ble) aka bluetooth smart. i used “android-x86-4.4-r2.iso” from

      before starting the vm, the bluetooth usb stick has to be inserted in the pc. after starting the vm with android 4.4 i only installed the mooshimeter app via browser. check if bluetooth is enabled and pair your mooshimeter device(s) in the bluetooth settings. then the mooshimeter app should see the devices.

      because the screen rotation problem, i installed “Ultimate Rotation Control” but this runs only 7 days unless the app has to be paid. there might be other free tools that do the same.

      i just found out, that i can use the graph mode even in the vm. switching between text and graph mode is done by STRG+F10 and STRG+F12.

      i have no experience with virtualbox, i only used vmware player but i saw on youtube that virtualbox should be fine too with using usb devices from the host.

      At last, here is a screenshot from the graph mode in the vm, while a solar panel was connected to the mooshimeter, y-axis is in correlation to the solar current:


    • #2354 Reply

      sorry for repetition, there was a big forum update lag…

    • #2356 Reply

      correction: i meant, the red line orrelates with the solar current, green with solar voltage.

    • #2378 Reply

      Hi Marc,

      Thanks for the swift reply. Yes, you’re right, I had 4.2 running, which resulted in the parsing error. Meanwhile I got the 4.4 running but still I’ve several problems to solve (Either Bluetooth or Wifi are not recognised (depending on the computer I use), so far) But I think I will get there. I got the app running and noticed the rotation… thanks for the tips concerning that too.
      I will post another reply once I have things running the way they should. It might help others as well.


    • #2413 Reply

      good, at least the first problem is solved. do you have the possibility to test with a lan connection? perhaps there are other problems with differnt emulators, that others might stumble across, too.

    • #2432 Reply

      Hi Marc,
      It works!
      The rotating I haven’t fixed yet, though (because I didn’t put any effort in it, so far ;-). I had another bluetooth 4.0 usb-adapter as you did: the Speedlink Vias SL-7411-BK (14 €) But it shows up in my VM as: CSR8510 just like yours.

      So here for all who would like to have the app running on their desktop/laptop computer under Windows, MacOs or Linux.

      The way I did it was through Oracle Virtual Machine…
      The first step is to download this free program.
      and select your platform

      Second step is to download the right = latest available (4.4 or higher) Android.iso file to install within the Virtual Machine.

      The right way to get the Iso installed is perfectly step-by-step explained on the following page:

      Once you have your Android running (and hopefully also your internet on it…)
      You download the app: and select the latest apk-file
      (when you do so within Androids browser, you can immediately install the app.
      However when the internet isn’t working (you don’t need internet in Android to run the app)
      you can do the following: Download the app to a usb stick.
      Once it is on a stick, you have to enable Android to mount/gain access to the stick.
      How to is similar to getting Bluetooth accessible for Android and explained below)

      The following lines explain how to get usb peripherals accessible and working for Android.
      Go to the Oracle VM VirtualBox Manager
      Open settings and select USB
      On the right side border select +
      Select the peripheral you want Android to gain access to (and take over the access from the host operating system until you’ve closed VM again)
      Select the Bluetooth adapter and/or the USB stick you need
      Wait for the host system to install the according drivers to the guest system and you’re done.

      Either you now install the app from your stick and get started, or you open the app and confirm the starting of Bluetooth.
      For me it worked!

      Oh and yes, the app runs rotated 90 CCW (or at least this version does).
      I use an old laptop, which either I set on its side or in which I set the whole desktop rotated in the nvidia software.
      (In that latter case it is useful to save your icon settings beforehand, and beware, using a mouse then becomes adventurous)
      And: in the top menu of your VM Android window you might need to go to: View (or something similar, I don’t use the English version) and select a scalable window.

      That’s it so far.

    • #2446 Reply

      Great summary, Matthijs.

      In the meantime i found another screen rotating app “Rotate Screen Orientation”, which seems to work similar h**p://

    • #2517 Reply

      Today I managed to make my first mooshimeter firmware update within a virtual machine with android 4.4 x86 on my pc. It worked fine on the first try and the mooshimeter still worked after that.

      I used the instructions for android from

      Nevertheless, everybody has to think for himself about possible risks before flashing from within an emulator.

Viewing 11 reply threads
Reply To: Mooshimeter connected with PC
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.