Topic | Parsing error

Home Forums Mooshimeter Support Parsing error

Viewing 7 reply threads
  • Author
    Posts
    • #1883 Reply
      Brad
      Guest

      Hi
      I too just received my meter.
      I downloaded the app and when I tried opening it I got a parsing error “there is a problem parsing the package”

      Samsung SPH-L300, Android 4.1.2

      Brad

    • #1885 Reply
      admin
      Keymaster

      Hi Brad,

      Sorry to bear bad news, but the Samsung SPH-L300 does not support Bluetooth Low Energy. Is there another device you could try?

      ~James

    • #2040 Reply
      Anonymous
      Guest

      Same problem here,

      GT-I9505 (Galaxy S4, International)
      Android Version 4.2.2

      Some digging around online hint that android version restrictions in the APK can cause the error.

      I have uploaded the following pics to https://imgur.com/a/CGMCZ#0
      Parse Error Message
      Droid Security Settings
      Droid Model/Kernel/Build
      APK Properties
      APK Handler
      APK Checksum
      AndroidManifestXML-Mooshi
      AndroidManifestXML-Other

      I included the AndroidManifest.xml to show the inclusion of:
      platformBuildVersionCode=”19″
      platformBuildVersionName=”4.4.2-1456859″
      where these (restrictions?) are not present in another APK which installed fine.
      File permissions and ownership for both APKs are identical.

      Also, no spare fuse with my MooshiMeter either :(

      Cheers,

      Rhys

    • #2047 Reply
      admin
      Keymaster

      Sorry Rhys, it looks like some shipments got packed without the extra fuse. Also some were packed with the fuse in the box/bag, but outside of the toolcase. Did you check the box?

      I’ll drop a fuse in the mail for you if you don’t find it.

      Regarding Android versions: the app presently targets Android 4.3 and above. A lot changed between 4.2 and 4.3 that makes 4.2 quite difficult to work with (the BLE implementations vary by phone manufacturer). I’m fleshing out features and working on stability before I try to backport anything. I can’t promise the app will work for 4.2 on all phones. With a Galaxy S4 I am pretty sure you can upgrade Android… would that be possible?

      Best
      ~James

    • #2080 Reply
      Anonymous
      Guest

      same here…
      parsing error when i try to install the app.
      ZTE Grand Xin
      Android 4.0.4

    • #2081 Reply
      admin
      Keymaster

      The parsing error is Android version, but that phone does not support BLE. Do you have another device you can try?

    • #2102 Reply
      Anonymous
      Guest

      James, could you please put information on this error message on the FAQ? I spent several hours (spread out over days) trying different versions of the app on my phone, always getting this error – while I understand it’s just that my phone is too old, it would have been nice to know earlier that this error proves it X)

      As an aside – how does the Bluetooth communication work? Is it a serial connection? And if so, would it be possible to communicate with the meter from a computer with an appropriate BT adapter? I don’t have a BLE USB adapter (yet), so can’t just fire up Putty and start testing baud rates…

    • #2135 Reply
      admin
      Keymaster

      Thanks Josh, added it to the FAQ: https://moosh.im/support/

Viewing 7 reply threads
Reply To: Parsing error
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.