Topic | Trouble connecting (Android)

Home Forums Mooshimeter Support Trouble connecting (Android)

Viewing 7 reply threads
  • Author
    Posts
    • #15382 Reply
      Anonymous
      Inactive

      It was working ok to begin with, but now, I am having a lot of trouble connecting to the meter. I typically see “Initialization failed. Status: -1”. I haven’t worked out any reliable method of connecting yet – I just keep trying, and eventually it works. (even rebooting the phone doesn’t help. Haven’t tried removing phone batteries yet but that’s a hassle)

      Environment:
      Samsung Note 5, Android 6.0.1
      Android app: 1.0.33 (2097)
      Downloaded firmware: 1477971088

    • #15386 Reply
      Anonymous
      Inactive

      Suggest you read my comments in this post = https://moosh.im/f/topic/android-ble-connection-problems/

    • #15389 Reply
      Anonymous
      Inactive

      Thanks – yep – looks like the same problem. I’m reluctant to try clearing my network cache – I shouldn’t have to do that, and in any case, I CAN connect sometimes even without doing that, so even if I can connect immediately after clearing my cache, it won’t really prove anything, because it may have connected that particular time anyway.

    • #15396 Reply
      Anonymous
      Inactive

      This is probably a red herring, BUT, FWIW, I went into Settings | More connection settings and disabled “Nearby device scanning”. I have not had a single failure to connect since doing that. (Android still presents a list of known BT devices when BT is enabled, though, which of course I cancel out of). However, even after re-enabling Nearby device scanning, it is still working flawlessly, so this is very tenuous. IF this really is a workaround, I would find this an acceptable workaround, because it’s a very quick & easy thing to do each time I use the meter. Having to “forget” all my other paired BT devices is not something I find very palatable. (if that did turn out to be a workaround)

    • #15398 Reply
      Anonymous
      Inactive

      I’ve noticed a behaviour which seems questionable. It’s not causing any obvious problems (and I’m still able to connect every time), but I’m reporting just to be thorough:
      Steps to reproduce:

      1. Place the meter close to the phone.
      2. Ensure BT is enabled.
      3. Stop the app completely by going into the Application Manager and doing a “Force Stop”.
      4. Start the app, and wait for the meter to appear. Do NOT connect to the meter.
      5. Tap “Scan”, and observe the RSSI value, which is probably moving around a bit.
      6. After a few seconds, the scan should complete, and the RSSI value should be steady.
      7. Holding the phone, move a bit further away from the meter.
      8. Tap “Scan” again. The RSSI value should be lower, and again, will probably be changing values a bit during the scan. The scan should complete again after a few seconds, and the RSSI value should again be steady.
      9. Connect to the meter.
      10. Tap the “back” button in the app (top left hand corner) to display the list of meters again.
      11. Just after tapping “back”, observe that the “Scan” button is greyed out, and the word “Scanning” appears just above the button, also greyed out.
      12. After a few seconds, the “Scan” button is enabled (suggesting that the scan has completed), BUT, the word “Scanning” persists, although it is no longer greyed out. Is this behaviour normal/expected?
      13. Now, still on the scan screen, and still with the meter connected, tap the “Scan” button. The RSSI value should change values a bit, and stabilise after a few seconds, at which point the “Scan” button is re-enabled. Move around a bit, and repeat, to observe that the RSSI value changes depending on your position relative to the meter.
      14. Now disconnect the meter, by tapping the “disconnect” icon to the right of the meter information. (the two plugs).
      15. Tap “Scan” again. This time, you should observe that the RSSI value does NOT change at all. It doesn’t matter how close or far away from the meter you are – the value does not change. Repeat as many times as you like – it never changes. This behaviour does not match the behaviour when the app is first started. When the app is first started, with the meter disconnected, the RSSI value DOES update each time the “Scan” button is tapped. Also observe that the word “Scanning…” persists throughout this last step, as if some process has locke
        d up.

      Now, despite the above, when I again tap on the meter, it does actually connect successfully.

    • #15425 Reply
      admin
      Keymaster

      Hi Greg,

      I think you’ve found many of the Android bluetooth issues that continue to haunt me. I do most of my Android testing and development on a Samsung Galaxy S6 Active running 6.0.1 and experience some of the same symptoms (rssi not updating, status 133 and -1, which refer to an unhelpful generic GATT error and a timeout respectively) from time to time. I don’t have much to add, because force closing the app, disabling and reenabling bluetooth is my usual panacea for these Android issues.

      Slowly BLE on Android is getting more reliable… 4.4 was a nightmare, 6 is much improved but still far from perfect. Sorry I don’t have a fast answer on this one.

      Best
      ~James

    • #15427 Reply
      Anonymous
      Inactive

      Ok thanks. It’s not so bad that it’s unusable – I’ll live with it, and it’s good that things are improving over time.

    • #15448 Reply
      Anonymous
      Inactive

      So I have the Status -1 today when trying to connect with my main Android.

      Made sure to kill the Mooshimeter program, cleared the Wireless Settings, sill no connection.

      Tried to scan for the Mooshimeter BT, did not see it on the meter.

      Turned off the BT on my phone that was on my belt.

      Finally decided to restarted the tablet and instant connection.

      Not sure what is going on, something maybe with the BLE stack in the tablet, I use a number of different standard (non BLE) Bluetooth wireless OBDII interfaces on this tablet an never have a problem with these, this is the only BLE device I think I connect to so far with this tablet.

Viewing 7 reply threads
Reply To: Trouble connecting (Android)
Your information:




This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.