Topic | Unable to resurrect mooshimeter after changing dead batteries

Home Forums Mooshimeter Support Unable to resurrect mooshimeter after changing dead batteries

Viewing 3 reply threads
  • Author
    • #19515 Reply

      Hi Guys, I have been searching the Wiki, the manuals and of course here on the forum so apologies if I’ve missed something.

      I have a Mooshimeter here that now has fresh batteries in it, the led is flashing around once a second but I cannot see the device on my previously paired PC, Mobile or Tablet.

      Most of the threads on here refer to replacing batteies,
      resetting the mooshimeter using the reset button,
      restting the mooshimeter by removing and refitting the batteries,
      checking it’s not in shipping mode (touching the leads together),
      rebooting the phone,
      removing and reinstalling the app,
      switching off WiFi,
      etc etc

      I have tried all these things in various orders and multiple times. I cannot seem to get anything more than a flashing LED. The meter does not show up in any app (mobile or tablet) where is has previously worked on both. Nor does it show in my PC settings which it previously did, I cannot recall if I ever actually paired the meter to my laptop but I do recall seeing it listed there.

      A little history on this, I bought this for a specific job from the website info that said it worked with amp clamps, when it arrived I tested it with voltage and current and it did indeed work with a amp clamp but due to the scaling being way out and no ability to set a scale the meter was of no real use to me. I have therefore had it tucked away safely in the garage.

      Since then I have regularly seen it in my mobile, tablet and PC, In fact because of it’s unique name I have had several guests ask me what a mooshimeter is, it seems only a couple of weeks since I noticed it’s absence. I have since purchased a BLE dongle to see if I could dev a Python app to do what I need.

      Having now fetched the meter from the garage and replaced the batteries I expected it to “just pop back up” but no such joy. The batteries I removed are definitely flat (0.6 – 1.0v) and the batteries I have put in are new.

      The meter has never been dropped or exposed to damp etc, so other than the batteries depleting I am not aware of any other possible influence.

      As far as I’m aware it was fully updated when I last used it and it was fully functional when it was put away.

      The build date on the pcb is 04/2015 and it’s model number appears to be dmm-ble-2x01a

      Any pointers would be much appreciated.

      Although I haven’t had much joy with it I love the concept of it and regularly check here on the forum for progress hoping it would one day do what I bought it for and I’m still hopeful now, hence buying the BLED112 dongle despite having BLE inbuilt in my laptop.

    • #19516 Reply

      Hi Paul,

      It sounds like you’ve done everything I would suggest, sorry for the trouble! Please email me at with your shipping address and I’ll get you a replacement ASAP.

      Sorry for the trouble,

    • #19522 Reply

      Hi James

      I had started to think it was end of the line for it as I had continued to battle with it since posting.

      Thanks for the very positive solution offered, a refreshing level of service.

      I have emailed you my details, thanks again


    • #19598 Reply

      Replacement Mooshimeter arrived yesterday and I now have it up and running ok, thanks once again for the excellent support.


Viewing 3 reply threads
Reply To: Unable to resurrect mooshimeter after changing dead batteries
Your information:

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.

The reCAPTCHA verification period has expired. Please reload the page.